New to Jeep KJ

Discussion in 'Just registered? Post here to introduce yourself!' started by Mytmouse, Dec 19, 2018.

  1. tommudd

    tommudd Moderator Staff Member Moderator

    Messages:
    17,208
    Likes Received:
    195
    Joined:
    Jul 14, 2005
    Location:
    Southeastern Ohio
    If you have the trash loc

    ( I still have about 20 bottles of that additive LOL )
     
    Last edited: Dec 29, 2018
  2. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Only if you have the Trac-loc.

    Follow Tom's advice on the oil weight. I use the 80w-90 in all mine since I don't do any serious offroading or towing.
     
  3. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Thanx guys looks like no mention of TT
    So just straight 75w-140

    DGBS All 4-Speed Automatic Transmissions
    DG6 4-Spd. Automatic 42RLE Transmission
    DHAP Lock-Up Torque Converter
    DHNS Command-Trac Part Time 4WD System
    DJJS Dana 30/186MM Front Axle
    DMEP 3.73 Rear Axle Ratio
    DRAS Corporate 8.25 Rear Axle EKG 3.7L V6 Engine

    *** >> Sooo 75w-140 for the front too?

    ..
     
    Last edited: Dec 29, 2018
  4. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ok, after getting the necessary info. for maintenance/service on this "New to me" 05 Liberty (just need to verify front diff fluid weight). A big THANK YOU TO ALL! :33:

    As mentioned, I plan on using this Liberty for driveway snow plowing with my Myers Home plow. Not for towing. (I have a BIG Ford F350 7.3 diesel for that). I've been thinking about the trans. temp. I don't plan on doing any towing in the hot summer, just plowing in the cold winter months with it...

    This Liberty did not come with the tow package, I was simply going to add an external Delare transmission cooler to it (from etrailers), but as I'm looking around I see it already has an external cooler in front of the rad. Thinking maybe,, or maybe not, good enough, I then decided to search on this forum what others have done, and oh boy, I came across alot of info., people wanting to add for towing and overheating issues.

    So from what I'm gathering I can;
    Either to add the HD cooling, missing from the tow package, (which I believe is changing ? the electric fan and shroud and adding the mechanical fan with clutch) . But I loose that nice space to get to the oil filter & such :icon_cry: ,, oh well...
    -And /or- change the rad to an 02 Liberty rad (that has the internal trans cooler along WITH plumbing the original extrenal trans cooler).

    I'm a bit confused now. I've read there's choices of fans (I have the 3 wire plug to my fan), and getting the correct clutch, ect. Any help/guidance is appreciated. Also if I got it right about the HD cooling (involving changing the electric fan, ect.). If any of you can simplify this for me/my needs, and if POSSIBLE to include part numbers of what I REALLY NEED? PLEASE [-o<

    See link for pictures:
    https://photos.app.goo.gl/LmBEZjhywSqWcx1d7

    I'm thinkg/ leaning towards just adding the HD cooling (fans/shroud/clutch)... That should pull in the necessary cool ambient air pass the existiing external cooler and rad. at the low speeds of plowing for my situation.

    Sorry, Not sure maybe I should start a new thread?
    -
     
  5. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Question with locking the Liberty with the key fob;
    Does it always have to beep /sound the horn at the first press of the lock button?
    Is there a way to reprogram it to not beep, or at least to only beep when the lock button is pressed twice like other vehicles?
     
  6. uss2defiant

    uss2defiant Full Access Member

    Messages:
    3,308
    Likes Received:
    18
    Joined:
    Jun 25, 2014
    Location:
    Tucson, Arizona
    yes. you can do that with the OTIS.
     
  7. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    OTIS or EVICis an overhead computer right?
    How does an overhead computer change the function of the Key fob?
     
  8. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ah , I think I found it ;
    http://www.jeepkj.com/forum/f202/how-tweak-your-keyless-entry-settings-25640/


    HORN CHIRP DISABLING / ENABLING
    This controls if you want your Libby to beep the horn when locking via the keyless entry. * Reports indicate that this does not work for 05 mdoels.
    To DISABLE (cancel) the horn chirp feature,
    Press and hold the transmitter LOCK button for four to ten seconds.
    While pressing the LOCK button in, press the UNLOCK button.
    Release both buttons.

    To ENABLE the horn chirp feature, repeat the above procedure.

    QUOTE=BluPhant;233326]Ya.. I knew you could do it with the EVIC, but didnt realize you could do w/o. Stumbled across this in the service manual when I was looking for something else.

    LMK how it turns out.

    -Blu[/QUOTE]

    , if you have not figured it out by now, that the 2005 Liberty Manual is misprinted. Mine is at least. For all of those who like me just got their 05 I hope this clears it up. It sure was frustrating trying to disable the horn honk when pushing the wrong button all of the 30 or so times I tried ..lol

    It should read ...

    To DISABLE (cancel) the horn chirp feature,
    Press and hold the transmitter LOCK button for four to ten seconds.
    While pressing the LOCK button in, press the PANIC button.
    Release both buttons.
     
    Last edited: Dec 31, 2018
  9. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    It changes the response by the vehicle to the fob. Doesn't do anything to the key fob. Just follow the menu or check out the owners manual. I have mine set to not beep when locking (parking lights blink) and when opening, it opens the driver's side door only with one press and all doors with two.
     
  10. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Thanx , but now this OTIS or EVIC overhead computer has got my interest to add..

    Hmmm how much, how hard, where to get one, what's involved with adding one?
     
  11. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
  12. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
  13. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    My 05 came with the EVIC installed. I've never done an install so maybe someone who has will be along soon.
     
  14. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Well reading through ALL these threads on EVIC installs, I went ahead and ordered a console retainer bracket p/n 5072348AA for $22 +s&h. Now my only things are from reading all these threads, I'm not sure if the EVIC I ordered from Ebay is right for my 05, and if it has the wire harness or at least the connector for me to make my own harness.
    I sent a note to the seller asking, but I'm not expecting a quick response.
    It figures that the plug/harness is hard to find, and expensive. Worse case I think I read, I can make something from an old floppy drive connector or something.

    Funny thing is, this all started just because I didn't want the annoying horn chirp when locking the doors with the key fob.
    Which I already fixed by following this :

    To DISABLE (cancel) the horn chirp feature,
    Press and hold the transmitter LOCK button for four to ten seconds.
    While pressing the LOCK button in, press the PANIC button.
    Release both buttons.

    Worked like a charm.

    But now I'm hooked/determined to get this EVIC with all the other features and programming choices it offers.... And spending more $$$$ that I didn't intend on.

    .
     
  15. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ok, I think I'm ok - ok but not great...
    Looking closer at the Ebay EVIC pictures I see the connectors for the lights AND the EVIC with small stubs of wire out of each. Maybe just enough for me to solder 4 wire trailer wiring to.

    And according to the "Installing an OTIS" how to web page it's the latest EVIC #56042756AJ

    s-l500.jpg
     
    Last edited: Jan 1, 2019
  16. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Dag nab it - so the console retainer bracket p/n 5072348AA I order online, came back as cancelled order due to discontinued part.
    So I guess my search for another console retainer bracket p/n 5072348AA is back on.


    .
     
  17. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Please Help identify correct part

    Ok, I went to my local auto wreckers and they came back with this (see below link for pictures).....

    I'm not 100% sure - they said it came out of a Cherokee.

    Is this what the retainer bracket is supposed to look like ? The numbers on it don't look like the p/n number I got from the threads here...
    Please advise?
    https://photos.app.goo.gl/5pxbjDhWszisXY1G8


    .
     
  18. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    If that is the correct retainer bracket (I'll know for sure when my EVIC from EBAY arrives, I suppose) how has the 3m tape method work out in the long run through hot & cold temps for you guys?
    If not someone suggested to me to use E6000 glue.....
     
  19. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    ‚ÄčOk I thought I had everything figured out and got all my necessary parts. I finally had some time to do this mod. First thing stopped me in my tracks - that is that the dome courtesy light plug / wiring is totally different in my 05 Liberty than the EVIC (56042756AJ) I got from Ebay. I'm going cross eyed from all of the 40+ pages from the HOW TO: Install an EVIC thread - I can't find the wiring difference and /or solution to this. Can anyone HELP!

    see link for pictures dome courtesy light plug / wiring differences

    https://photos.app.goo.gl/iPu1Z4SYpL8RpCTD6



    .
     
  20. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I figured out/found the courtesy dome light plug wiring and lights working backwards dilemma from post #96 & #97 from the HOW TO Install an EVIC thread. Now I just have to figure out how to change/move the wiring within the plug.

    As I mentioned last night I hook up the EVIC and powered it up briefly. I did not cut the head linener/mount it yet - the no turning back portion, until I was sure everything is working. All seems to be working except the Temperature reads --F .
    The EVIC I got is from a 2004 GC, which reading here, multiple times, says an 04 or newer EVIC will work for my 05 Liberty temp reading to work. I do have a temp sensor installed, even purchased an additional new one, same result. Some say it might just need to register different temps for more than 5 min. I have the Liberty still in my garage as I'm working on other things, so I haven't kept it on longer than 5 min.
    I have a few other issues like only one tire is not reading pressure, but the other three show 33,33,32 , I didn't even think I had TPMS sensors in ths tires?..?..?. Also only the front drivers and front passengers door register open/closed, not the any of the rear doors or glass/gate, but still does show on the dash.

    See pics - I used tap a fuse on #13 fuse position, and the OBD adapter worked out nice , hope the cutting of the headliner comes out as well..
    https://photos.app.goo.gl/URTiTA7KL2sDZ93C6


    -TC
    _______
    [_] [___]
    l-----{o||||o}
    ()_) ()_)-o-)_)

    "Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the present." -Master Oogway (KungFu Panda)