Rear glass only unlatches with keyfob

Discussion in 'KJ General Discussion' started by Ksat, Nov 11, 2018.

  1. Ksat

    Ksat New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 11, 2018
    Location:
    ny
    Hi everyone, Nooby member to your site here and (so far) a proud new owner of an '06 Liberty,

    Having an apparent issue with the rear glass, Specifically, it doesn't want to unlatch itself from the door there when I pull handle. The door opens fine, though it's just prevented from opening very much because the glass is still hanging on to it. The glass does open fine when I push the related button on the keyfob, though.

    I removed the panel on the door and noticed what looks like a remote switch on the door handle wired to the left side of the latch switch (when facing rear of vehicle). I removed the connector on the latch and jumped the two pins in there hoping maybe i just had a bad switch on the door handle, but nuttin happened.

    Anyone know what might be up?
     
  2. Cardhu

    Cardhu Full Access Member

    Messages:
    683
    Likes Received:
    0
    Joined:
    Aug 29, 2011
    Location:
    Great White North
    your switch on the door handle is dead. Mine shorted out and would randomly close/open the circuit and pop the rear glass.

    [​IMG]
     
  3. Ksat

    Ksat New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 11, 2018
    Location:
    ny
    Thanks very much for the reply. If the switch was bad, wouldn't me shorting the 2 pins on the actuator connector (circled in red) have opened the latch?
     

    Attached Files:

  4. turblediesel

    turblediesel memberable

    Messages:
    2,283
    Likes Received:
    121
    Joined:
    May 31, 2015
    Location:
    Elbonia Alaska
    Cardhu's right. It's the microswitch in the doorhandle that's bad. It actuates the actuator in your picture. Your actuator works with the fob so it's good.
     
  5. Billwill

    Billwill Full Access Member

    Messages:
    1,501
    Likes Received:
    143
    Joined:
    Nov 26, 2009
    Location:
    White River, South Africa
    That switch is known to have failed a lot due to water ingress.

    Chrysler did send out a TSB for its replacement but I cannot remember what the fix was...probably a more water-proof switch!
     
  6. Cardhu

    Cardhu Full Access Member

    Messages:
    683
    Likes Received:
    0
    Joined:
    Aug 29, 2011
    Location:
    Great White North
    I think the solution was replace the 10 ( or 1 if your looking at cost) dollar part and make it another 8 years.
     
  7. Ksat

    Ksat New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 11, 2018
    Location:
    ny
    Thanks for the replies but I don't want to replace the switch if that's not the problem. I stopped by the local jeep dealer and the parts guy told me I could ask one of the techs when theyre on duty if all that switch does is make continuity at the two pins at the actuator. If it does, then I've got an issue there, instead
     
  8. turblediesel

    turblediesel memberable

    Messages:
    2,283
    Likes Received:
    121
    Joined:
    May 31, 2015
    Location:
    Elbonia Alaska
    Try this:

    * Unlock doors

    * Close rear door and glass

    * Sit inside the cargo area with the inside plastic off the rear door

    * Use a paper-clip to connect the two wires in the connector that the little switch in your photo plugs into... window should pop open

    * Replace the switch, $12.95 when I did mine
     
  9. Jeremy-WI

    Jeremy-WI Full Access Member

    Messages:
    215
    Likes Received:
    37
    Joined:
    May 20, 2017
    Location:
    Home
  10. Ksat

    Ksat New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 11, 2018
    Location:
    ny
    I did a little more investigating back there and found it is the switch on the door handle after all that's causing my problem, as most of you suggested. I did actually figure out what those 2 connectors on the actuator actually do, so if anyone's curious about feel free to read on.

    Referring to the uploaded pic, the 2-wire connector circled in yellow is what applies momentary battery voltage to unlock the latch. This is done by the computer either when it senses the "open hatch glass" button on the remote is pushed or when the handle on the rear door is pulled when it thinks all doors are in the open position. The 2 wire-connector on the other side circled in red is what's involved with telling the computer (which then alerts the operator) that the glass on the hatch has not been closed properly. It works by applying ~2V less than battery voltage (10.6V in my case) at the connector. Inside the actuator on that side is a simple switch which either shorts those wires together or leaves them open depending on the latch position (open or closed).

    So that's it.. Nothing too complicated.

    While I'm here, would anyone happen to know what the part number for that door switch is?
     

    Attached Files:

    Last edited: Nov 26, 2018
  11. Billwill

    Billwill Full Access Member

    Messages:
    1,501
    Likes Received:
    143
    Joined:
    Nov 26, 2009
    Location:
    White River, South Africa
    Yeah the unlocking of the rear window can get a bit more complicated. The window will not flip up unless it is sure that the rear wiper is out of the way ie. in its "Park" position.
    So if the Wiper Park signal is faulty the pop-up window will just ignore your actions either from your key-fob or from opening the rear cargo door!
    The BCM handles all of these actions.

    I have read of owners buying that cargo door micro switch from Radio Shack but we do not have Radio Shack here so I cannot comment.!
     
  12. nohitter64

    nohitter64 Full Access Member

    Messages:
    150
    Likes Received:
    2
    Joined:
    Sep 18, 2011
    Location:
    Annapolis, MD
    I was able to clean the switch, cut the corroded portion out and resolder. Was able to reuse the switch. Slathered it with silicone and it still works. 45 minutes start to finish.

    Sent from my SM-G950U using Tapatalk