EVIC for '05 Renegade 3.7l??

Discussion in 'How To' started by stevecon, Jul 30, 2018.

  1. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    ​Ok I thought I had everything figured out and got all my necessary parts. I finally had some time to do this mod. First thing stopped me in my tracks - that is that the dome courtesy light plug / wiring is totally different in my 05 Liberty than the EVIC (56042756AJ) I got from Ebay. I'm going cross eyed from all of the 40+ pages from the HOW TO: Install an EVIC thread - I can't find the wiring difference and /or solution to this. Can anyone HELP!

    see link for pictures dome courtesy light plug / wiring differences

    https://photos.app.goo.gl/iPu1Z4SYpL8RpCTD6



    .
     
  2. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I figured out/found the courtesy dome light plug wiring and lights working backwards dilemma from post #96 & #97 fromthe HOW TO Install an EVIC thread. Now I just have to figure out how to change/move the wiring within the plug.

    As I mentioned last night I hook up the EVIC and powered it up briefly. I did not cut the head linener/mount it yet - the no turning back portion, until I was sure everything is working. All seems to be working except the Temperature reads --F .
    The EVIC I got is from a 2004 GC, which reading here, multiple times, says an 04 or newer EVIC will work for my 05 Liberty temp reading to work. I do have a temp sensor installed, even purchased an additional new one, same result. Some say it might just need to register different temps for more than 5 min. I have the Liberty still in my garage as I'm working on other things, so I haven't kept it on longer than 5 min.
    I have a few other issues like only one tire is not reading pressure, but the other three show 33,33,32 , I didn't even think I had TPMS sensors in ths tires?..?..?. Also only the front drivers and front passengers door register open/closed, not the any of the rear doors or glass/gate, but still does show on the dash.

    See pics - I used tap a fuse on #13 fuse position, and the OBD adapter worked out nice , hope the cutting of the headliner comes out as well..
    https://photos.app.goo.gl/URTiTA7KL2sDZ93C6


    -TC
    _______
    [_] [___]
    l-----{o||||o}
    ()_) ()_)-o-)_)

    "Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the present." -Master Oogway (KungFu Panda)
     
  3. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I now had the Liberty out in the driveway running longer than 5 min. STILL NO TEMP. reading.
    Does this mean I NEED AN EVIC FROM AN 05 OR HIGHER.... ?

    .
     
  4. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I believe we need an EVIC out of an 04, or 05 to 07 LIBERTY specifically?
    I have an Ebay seller who has a few andrelized that, and is asking the part number - he recalls the Liberty's EVIC having a bit different part number from a previous transaction. ..

    Does anyone know what the part number(s) would be for an 04, 05, 06 ,or 06 for an EVIC specifically from a Liberty?
     
  5. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Now to add to my EVIC issues - besides the -- F for the temp. I now noticed all of a sudden when the kids get in the back (open both rear doors) only the right rear started showing open and never clears (shows closed) when the doors are closed. I have to unplug the EVIC to get it to stop showing - only until my daughter opens the right rear door again.
    I'm leaving this EVIC DISCONNECTED and going back to just the map courtesy lights until I find the PROPER EVIC ....

    .
     
  6. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ebay seller mentioned this;

    The last numbers 57aj or 49aj the 56 is tps but I know the liberty has the first half of the number is different..

    Any help/ idea of the Liberty part number?

    .
     
  7. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Try this 56010438AD
     
  8. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Got another EVIC (from 05 Liberty) wires different coloring

    I just found another EVIC at a wreckers out East of me - they say it's from an 05 Liberty part number P/N 56010520AD...

    I see that the wire colors for the EVIC plug are different and the Courtesy Dome light plug is the same as in my 05 Liberty, which is a plus (I wont have to mess with that wiring)...

    Now I'm wondering if the way I wired my wiring from the Jeep Grand Cherokee WJ - Overhead console and EVIC and Installing an OTIS How To install an EVIC is going to work?
    The say :
    EVIC pin #5 Blue / White to fused ignition switch Output (#13 fuse block)
    EVIC pin #4 Black/Orange to pin #4 of the OBD port > GROUND
    EVIC pin#3 Pink to pin #16 of the OBD port > FUSED B (+)
    EVIC pin#2 Yellow/Violet to pin #2 of the OBD port > PCI BUS

    Where as this (05 Liberty) EVCI plug has:
    EVIC pin#5 Pink / Green
    EVIC pin# 4 Black/White
    EVIC pin# 3 Red
    EVIC pin# 2 White Violet

    See Pictures:
    https://photos.app.goo.gl/9itUksTtsjE9Bzck7

    .
     
  9. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    IF the pins/functions to the EVIC are all be the same ( ? )

    If so then the color code of the wiring does NOT matter as long as the pins/function at the EVIC are the SAME....???....????

    Can anyone Confirm this for me ?

    .
     
  10. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    I don't remember where but I guess in the 42 pages post someone said something about it.
     
  11. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    "Wire Colors May Vary"

    Found it -I missed the note that says "WIRE COLORS MAY VARY"


    .
     
  12. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Wait am I reading the How to thread correctly - that if this is an 05 EVIC to get the TPMS to work, it is not just a matter of getting 4 (or 5) tpms sensors and a Retraining magnet ?
    That the 05 that came with TPMS as an option has a different set up - external antenna's in each wheel well?
    .
     
  13. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I did not connect this next EVIC up yet - the dealer has my Liberty right now for a recall - Installing a rear hitch for free :happy107:

    I'm confused what EVIC this is then from the provided list does not match any.....,?

    I was hoping to add TPMS to my Liberty after adding the 05 Liberty EVIC that has Home link & TPMS (I thought it did - maybe not??). To just get the proper tire sensors and just use the learning magnet (I already have the tire learning magnet, it's a doughnut shaped magnet and goes over/around the tire valve) - that's what I was working on/ looking for what proper sensors to get, when I came across this comment, post #192 of the How to install an EVIC....
    So according to this comment, by me adding the 05 EVIC I just got that I think has TPMS, it's not just a matter of adding the tire sensors ? The Liberty would have to have this other module and three wheel well antennas?

    .
     
  14. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    But your EVIC part number does not show PSI.
     
  15. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    By the way, which is your ebay seller and how much did you pay for your evic?

    I am looking for a 2004 evic psi and also a light bar switch.
     
  16. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    OK - So then I don't have to worry about spending even more $$ to get the TPS to work and having to be annoyed by the warning bings and monitor of low pressure...
     
  17. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York

    I've been dealing with lastminutes > Jonathan who I got the pigtail from and he has multiple consoles

    https://www.ebay.com/str/lastminutes

    I got the first EVIC from someone else > codsel2 for $73

    https://www.ebay.com/str/oempartsby44autoco


    This lastest EVIC I got from a wrecker out east of me for $35...


    .
     
  18. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Ok thanks for the info, I was dealing with Lastminutes as well but they are expensive, and my biggest problem is shipping because I am overseas.
    Little sellers do USPS standard shipping which is the best option.
     
  19. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    ​Ok, I just had enough time to plug in this latest EVIC ​​aaaannnd (wait for it......) everything works just the way it's supposed to - like it was there the whole time. temperature readings, doors open/closed, avg mpg, miles to empty, compass, ect..... And NO TPMS :icon_razz:

    Now I just have to CUT THE HEAD LINER....!
    What did you all use and was the easiest / precise way to cut the opening? I was thinking a Sharp Razor/carpenters knife?
    I did get a section of the headliner while I was at the junk yard when I got the EVIC and bracket, to use as a template.
    SEE PIC :
    https://photos.app.goo.gl/VkDxy4HQ8JLWh3iW6



    .
     
  20. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Excellent, you did it!!
    And yes I used a carpenter knife just be sure to mark with a pen first, then snap in the overhead without the evic so you can check if it fits correctly.
    Myself I did not have any template so I just made a cut about 5mm inwards the overhead borders..
    For the screw I did not cut around it, so it goes thru the foam of the headliner, But you should use your template.

    When you make the cut go slow, take your time and make it with care. Dont cut in layers, cut with the knife completely thru the headliner and work it up and down in short and slow motions, in a few seconds you will feel what speed and pressure is the best for the job to be done.
    Good luck!