EVIC for '05 Renegade 3.7l??

Discussion in 'How To' started by stevecon, Jul 30, 2018.

  1. stevecon

    stevecon New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jun 26, 2018
    Location:
    Massachusetts
    My head hurts. I just got an '05 KJ and I've been reading and searching both here and other sites - trying to figure out what I need to upgrade to an EVIC. I have keyless entry in my KJ, so I understand that I have a BCM that supports the EVIC. So far, so good!

    I have TPMS on alloy wheels (including the spare) and an indicator on the dash lights up when a tire's air pressure goes low.

    I am confused about seeing *somewhere* that I need to use an '05 or later EVIC in my KJ for it work properly. Everywhere I look to learn about compatibility, the info talks about EVIC devices made between 1999 and 2004 - nothing later. Yet, I see people installing them successfully in KJs newer than '05 (see: Installing an OTIS).

    I *need* an EVIC that provides Homelink connectivity. Everything else is fluff. *If* there are some EVICs that provide greater detail (ie: "Driver Door Open" as opposed to generic "Door Open" or actual tire pressures instead of just a low pressure warning, and so forth) that would work in my 05, I'd LOVE to hear about them.

    I have also seen that if there is an indicator on the dash for a TMPS warning, that that warning will not appear on the EVIC. Is there truth to this or am I being misinformed?

    Any / all information provided about EVICs suitability for use in my '05 would be very much appreciated! EVIC model numbers of course, are *most* helpful! Thanks!
     
  2. Leeann

    Leeann Full Access Member

    Messages:
    2,269
    Likes Received:
    32
    Joined:
    Mar 9, 2013
    Location:
    Maryland
    All the info you need is there, on Installing an OTIS:
    Installing an OTIS

    Though you don't need to install an ambient temp sensor as there's one installed already.

    EDIT: I picked up unit 56010438AD from a member on here; it's an EVIC with PSI that says it's for 2004 only, but worked in his '05.

    Also, 56042749AB is an EVIC with HomeLink and works in 2002 2003 2004 2005 2006 Jeep Liberty


    Whatever you do, make sure you get the wiring harness. At least a foot with the connector, otherwise you're buying the wiring harness (a foot or so with the connector) on eBay for more bucks.
     
    Last edited: Jul 30, 2018
  3. stevecon

    stevecon New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jun 26, 2018
    Location:
    Massachusetts
    Hi -

    I got an EVIC on ebay and installed it in my '05 Liberty. This was by no means a "simple" task. My front dome light simply clipped to the headliner only - there was no cup-like receiver with slotted openings to secure the EVIC with its clips (or a place for the screw). I had to get one and remove the entire headliner to install it. That took me about 4+ hours. Ugh. Anyway, the EVIC I got was a #56042749AF and it is installed and somewhat functional..

    I noticed two issues. The "Instant MPG" always displays "0" and more importantly, the "Outside Temperature" always displays "--" (double dash). My Liberty does have the air sensor installed and I removed it for testing with an ohm meter. The resistance is tracking temperature changes without a problem. While it was out, I looked at the EVIC display. I expected to see "OC" or some crazy value temperature - but it continued to display "--" I don't really care about the instant MPG, but having the outside air temperature displayed would be nice. Is there something I missed??

    Thanks!
     
    Last edited: Aug 23, 2018
  4. stevecon

    stevecon New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jun 26, 2018
    Location:
    Massachusetts
    So - the saga continues. I now own 3 different EVIC with different numbers - all of which supposedly will "work' in my Liberty. Two of them do, as long as I don't mind a double dash (-- F) for temperature.

    The most recent one - 56010438AD - from an 04 Liberty solved the "-- F" temperature display issue. However.. I was shown a low tire pressure warning (21 PSI) for the left front tire. Even though none LOOKED low, I checked with a gauge and found all tires (I did not check the spare) were in proper range. While showing the 4 tire pressures - I pressed the RESET button and all values eventually displayed "-- PSI" (I don't recall if it happened immediately or not). I am also now getting a "BAD / MISSING SENSOR" message. I attempted retraining of sensors - as explained for the 04 Liberty (the '05 Liberty TPMS retraining is apparently automatic) with a speaker magnet (no magnet was found in -or likely included with- my 05).

    The retraining times out with a "Training Aborted" message on the EVIC. At this point - I'm pretty much fed up. So called "guides" seem to lack some pretty important information - that I have only learned after buying EVICs and searching deeper to find out why they don't work. How far do I have to dig? How will I know when I have dug far enough??

    I suspect that the TPMS modules for the '05 are *NOT* the same as those used in the '04 model year and no amount of twiddling is going to make this 04 EVIC work in my 05.

    I'm now at the point of asking SPECIFICALLY which EVIC model (with Homelink) were installed in 2005 3.7l Jeep Liberty Renegades? Anyone? Please? TIA
     
    Last edited: Sep 10, 2018
  5. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Hi all, I know this is an old thread , I'm new to this forum and I'm trying to understand and make sure I get all the necessary parts and information for installing an EVIC in my New to me 2005 Jeep Liberty Sport as well.

    This looks like a good one. I hope this will work for me better than the trouble Stevecon had.
    ***So beside the ambient temp sensor, do I also need the bracket to attach to the 05 roof ? From what I'm reading I think the 05 does not have a bracket to attach ths EVIC to?
    If I do, what do I search for, or what is the part number?
    I don't have to care to have TPMS. I thought the difference in getting an early than 05 EVIC was just that you have to rearrange the connector wires...??

    https://www.ebay.com/itm/99-04-OEM-G...edirect=mobile

    Not sure it's the same interior color. In some pictures it does look like my color, but in other pic it looks more tan.... I believe mine is more of a pewter color, my build sheet says -J3 Khaki .
     
    Last edited: Jan 1, 2019
  6. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Hello Mytmouse
    Mine its a 2004 Liberty and came with just the courtesy lights, no EVIC or OTIS, I removed the Lights and i could see the bracket was there, so i did buy the console. Now everything works great, except the ambient temperature which shows just dashes "_ _".
    Take a look at this link, it will tell you everything you need. Installing an OTIS
     
  7. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Well reading through ALL these threads on EVIC installs, I went ahead and ordered a console retainer bracket p/n 5072348AA for $22 +s&h. Now my only things are from reading all these threads, I'm not sure if the EVIC I ordered from Ebay is right for my 05, and if it has the wire harness or at least the connector for me to make my own harness.
    I sent a note to the seller asking, but I'm not expecting a quick response.
    It figures that the plug/harness is hard to find, and expensive. Worse case I think I read, I can make something from an old floppy drive connector or something.

    Funny thing is, this all started just because I didn't want the annoying horn chirp when locking the doors with the key fob.
    Which I already fixed by following this :

    To DISABLE (cancel) the horn chirp feature,
    Press and hold the transmitter LOCK button for four to ten seconds.
    While pressing the LOCK button in, press the PANIC button.
    Release both buttons.

    Worked like a charm.

    But now I'm hooked/determined to get this EVIC with all the other features and programming choices it offers.... And spending more $$$$ that I didn't intend on.

    .
     
  8. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ok, I think I'm ok - ok not great, but ok.
    Looking closer at the Ebay EVIC pictures I see the connectors for the lights AND the EVIC with small stubs of wire out of each. Maybe just enough for me to solder 4 wire trailer wiring to.

    And according to the "Installing an OTIS" how to web page it's the latest EVIC #56042756AJ


    s-l500.jpg
     
  9. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
  10. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    I just saw your image, I think you are good to go.
    I did the same, just run 4 wires thru the head liner. and down the A pillar, its easy.
    good luck
     
  11. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
  12. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Wait I scrolled down in his listing /description and I don't see a 56042756AJ listed... oh well THANKS SO MUCH FOR LOOKING for me though...

    I sent the seller asking to be sure anyways.
     
    Last edited: Jan 1, 2019
  13. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Thank you Sir
     
  14. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Dag nab it - so the console retainer bracket p/n 5072348AA I order online, came back as cancelled order due to discontinued part.
    So I guess my search for another console retainer bracket p/n 5072348AA is back on.


    .
     
  15. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Please Help identify correct part

    Ok, I went to my local auto wreckers and they came back with this (see below link for pictures).....

    I'm not 100% sure - they said it came out of a Cherokee.

    Is this what the retainer bracket is supposed to look like ? The numbers on it don't look like the p/n number I got from the threads here...
    Please advise?
    https://photos.app.goo.gl/5pxbjDhWszisXY1G8


    .
     
  16. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    If that is the correct retainer bracket (I'll know for sure when my EVIC from EBAY arrives, I suppose) how has the 3m tape method work out in the long run through hot & cold temps for you guys?
    If not someone suggested to me to use E6000 glue.....

    ..
     
    Last edited: Jan 3, 2019
  17. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I.
     
    Last edited: Jan 3, 2019
  18. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    How did it go, did you get the temperature reading with the new EVIC?, please let me know so I might get one of those.
    Thank you
     
  19. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I haven't received all my parts yet, but when I do, and I get the time to do the install, I'll let you know here.

    As I read through the many EVIC threads, I plan on wiring / connecting my EVIC using these;

    iKKEGOL 16 Pin J1962 OBD2 OBD-II Male Connector to Open Plug Wire, OBD Diagnostic Extension Cable Pigtail for DIY (60cm 24" inch, 2ft)
    by ebuyerdeal
    Learn more: https://smile.amazon.com/dp/B07F16GPMB/ref=cm_sw_em_r_mt_dp_U_DxOnCbJFQ7R12

    with this

    GEMWON OBD2 Extension Cable, 2 in 1 OBDII 16 Pin Female to Male Connector Diagnostic Extender Flat Ribbon Cable 60cm/2ft
    by GEMWON
    Learn more: https://smile.amazon.com/dp/B071WY9LFN/ref=cm_sw_em_r_mt_dp_U_EAOnCb1AB1ZRS

    To not have to splice into the back side of the OBD wiring. I will only have to run the key on wire to (I believe) #13 fuse position in the fuse block, or splice into any key on wire/circuit...

    .
     
  20. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    About your braket I coul not help you, mine it works perfect but i can not see the part number to help you.
    Also, I did splice mi wires into the back of the OBD, I hated it to do it but at the end is not seen and well hidden.
    Your setup will be better.

    By the way, if you ever see an EVIC from a Jeep Liberty 2004 with ALL included, Homelink and TPMS I would appreciate if you can let me know, I am just preparing myself in case i can not solve the issue of my EVIC, which is 2002 from a Grand Cherokee.

    I posted this thread EVIC dont show ambient temperature, only dashes "_ _" , so maybe we can solve this with a little help from everyone interested and I get to have also the Instant MPG.