Automatic Gearbox Problem.

Discussion in 'KJ General Discussion' started by Nicko1911, Aug 1, 2020.

  1. Nicko1911

    Nicko1911 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Nov 11, 2019
    Hi,

    I have a 2003 Liberty V6 Auto.
    About 2 months ago the gearbox went into limp mode whist on a highway. Managed to get home.
    I noticed the gearbox oil smelt burnt and a bit dirty.
    When I bought the car a few months before this happened I did notice that if I accelerated from a stop, there was a shudder. Now the car slips in first gear taking off, under anything but gentle throttle. I cant drive it up a steep hill unless I use little throttle. I have been nursing it to get around for a couple months now. Seems to drive ok when at higher speeds but if I put my foot down and it downshifts, it'll go into limp mode.
    Does this sound like I need to replace the gearbox?
    Are these gearboxes problematic? If so, I'm assuming I shouldn't bother replacing with another used gearbox?

    Cheers.
     
  2. tommudd

    tommudd Moderator Staff Member Moderator

    Messages:
    17,951
    Likes Received:
    477
    Joined:
    Jul 14, 2005
    Location:
    Southeastern Ohio
    They are not a problem "IF" they have been taken care of , i.e. fluid and filter changes when needed etc ,
    problem is many people in todays world think of any vehicle as a disposal vehicle, run it until it has an issue then trade it off
    You need to have it rebuilt , buying a used one is buying a pig in a poke, maybe a good one, maybe not
     
  3. LibertyTC

    LibertyTC Well-Known Member Staff Member Moderator

    Messages:
    7,208
    Likes Received:
    433
    Joined:
    Oct 24, 2008
    Location:
    B.C. Canada
    ^^^What Tom Said^^^
    I'm picky and service the trans with Atf+4 fluid & filter every 50k miles.
     
  4. 03GoingStrong

    03GoingStrong Full Access Member

    Messages:
    106
    Likes Received:
    40
    Joined:
    Jun 26, 2020
    Sounds kinda similar to what mine does when low on ATF+4 transmission fluid. Mine started slipping / hesitating / hard shifting when going into some gears under certain situations. It just didn't shift smoothly at all. The fluid level looked pretty good (check the fluid level after everything is warmed up to operating temp and with the engine running, transmission in neutral and parking brake on).

    I remembered reading somewhere that someone mentioned their transmission worked best if slightly over the full mark. I thought, what the heck do I have to lose ... and added about 6-8oz of fluid. I was somewhat shocked to find the transmission smoothed out to almost, but not quite, good as new. I added a couple more ounces just for good measure. I also disconnected and reconnected the battery so the transmission would relearn but that probably wasn't necessary.

    The thing is ... overfilling the transmission COULD cause some of the same problems ... and WORSE !!! So it's critical not only to service the transmission at suggested maintenance intervals, but not overfill it to the point of malfunction. If yours is overfilled, first thing would be to get it back down to the normal full mark. Mine is slightly over the full mark but is necessary for MY Jeep's transmission to operate smoothly. YMMV

    I have less than 55K miles on my low mileage 2003 KJ but had the transmission fluid and filter changed at the local Jeep dealership a couple of years ago.