Coolant overflow without overheating

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
Ok, I installed the OEM Oil pressure switch and the oil pressure light still turns on at low RPM’s after a few minutes. I am out of answers right now. Anyone have any ideas? Reminder, the oil pump is new.
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,703
Reaction score
1,290
Location
B.C. Canada
Just want to confirm you have the correct oil pressure sending unit part #, see image attached.
What is the rpm reading when oil light comes on? When you increase rpm does light go out?
How many miles are on your 3.7 engine?
Are you using 5w-30 synthetic oil?
 

Attachments

  • Oil Pressure Sensor.jpg
    Oil Pressure Sensor.jpg
    172 KB · Views: 4

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
RPM’s are at about 700, milage is 140,000 and when I accelerate slightly it turns off. I would love to here possible solutions. For now am thinking that I may have use a couple of my other vehicles oil by mistake (10-w30). I’m going to drain the oil and make sure I add 5-w30 and test the vehicle again. I do have 5-w30 synthetic. Thank you very much for replying.
 

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
Sorry, I forgot to tell you the switch is the correct part number.
 

Attachments

  • 67F37CDD-BBDA-4A66-9B32-6BA5E033B366.jpeg
    67F37CDD-BBDA-4A66-9B32-6BA5E033B366.jpeg
    78.2 KB · Views: 1

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,703
Reaction score
1,290
Location
B.C. Canada
Good u have the correct part#.
Drain the oil yes, & new filter.. try a Napa Gold oil filter...5w-30 synthetic ..
I also add synthetic LubeGard bio-tech engine treatment, quietens down engine big time, & oil will then be much cooler due to less friction.
 

Attachments

  • LubeGard Bio Tech Info.JPG
    LubeGard Bio Tech Info.JPG
    581.4 KB · Views: 6

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
Hey! Thanks for the Biotech recommendation, it sounds really good, I’m going to buy it. I‘ll take these steps and call out the results. Thanks again Liberty TC.
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,703
Reaction score
1,290
Location
B.C. Canada
BTW the LubGard Biotech comes in either 15oz, or (10oz size bottles in Canada)
When I had access to the 150z bottles up from the USA, I'd only add 10 ounces, & have 5 ounces left over for next time.
 

Attachments

  • LubeGard Bio Tech 15 10 OZ.jpg
    LubeGard Bio Tech 15 10 OZ.jpg
    560.3 KB · Views: 2

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
Well, I changes the Oil to the correct 5W30 and I drove the vehicle for 15 min. Approximately. I did not drive highways so its too early to tell if its fixed yet another issue came up!! The heater hose/tube started leaking coolant at one of the factory hydraulic pressure seals. This is worrisome because that part was also new. I am starting to think that the cylinder heated vapors are entering the cooling system thus increasing the pressure and that may have busted the heater hose/tube. My latest effort was ordering the OEM heater hose/tube assembly. I am seriously thinking this is my last effort to fix this jeep. This process has been sooo frustrating. I will check and see how things go with the new OEM part and go from there. Part takes 2 weeks to arrive. Wish you guys a great weekend.
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,703
Reaction score
1,290
Location
B.C. Canada
& to relieve the stress...
There is a solution to every problem and it's..
You must be registered for see images attach

;)
 

duderz7

Full Access Member
Joined
Jan 20, 2016
Messages
866
Reaction score
405
Location
Weiser, ID
FYI Zerex G-05 is HOAT we need so you don't have to buy Mopar brand.
Same thing for ATF+4. you can get the cheapest.
I was in a Napa a couple weeks ago and I'm pretty sure I saw a Napa brand hoat on the shelf right next to the Zerex G-05 for a couple bucks less. It was not the reason I was in there so I didn't look too closely. Can anyone confirm this? Thoughts?
 

uss2defiant

Full Access Member
Joined
Jun 25, 2014
Messages
3,566
Reaction score
138
Location
Tucson, Arizona
I was in a Napa a couple weeks ago and I'm pretty sure I saw a Napa brand hoat on the shelf right next to the Zerex G-05 for a couple bucks less. It was not the reason I was in there so I didn't look too closely. Can anyone confirm this? Thoughts?

i just googled it. looks like napa north american gold is listed as hoat.

looks like PEAK Original Equipment Technology Antifreeze + Coolant for North American Vehicles - Gold is listed as hoat too.
 
Last edited:

uss2defiant

Full Access Member
Joined
Jun 25, 2014
Messages
3,566
Reaction score
138
Location
Tucson, Arizona
sorry to hear that.
Maybe time to get some professional help before this becomes a parts cannon fix?

Perhaps do a block tester? you can get the part as a loaner, you'll just need to buy the fluid. only if you lived close to me, i'd let you use what tester fluid I have left.

I'm not sure, but does an engine compression test help diagnose a HG leak?
 

piroco66

Member
Joined
Mar 14, 2020
Messages
35
Reaction score
12
The heads were resurfaced a couple of months ago. Still waiting on the part. Will keep in touch
 

Latest posts

Members online

Top