Random Misfire 2007 Liberty

ArmySloth

New Member
Joined
Feb 22, 2022
Messages
10
Reaction score
3
Yeah mix up I think. Nothing to worry about. They will probably be like dang sorry, lets exchange.

I used All Computer Resources and had no issues other than they are just like all of the other places and can't possibly know everything about every model.

I had to send in my VIN and mileage, etc. Fired right up and rolled. No ETC light or anything.
They asked a couple questions and asked me to send it back so they could fix it. No harm done. I’ll update once I get it back.
 
  • Like
Reactions: JRB

3-LIB3RTYS-3

New Member
Joined
Mar 28, 2022
Messages
10
Reaction score
3
Location
Nevada
Hey Everyone,

Tagging along on this thread but it seams like this is the problem my 2004 Liberty is having. 2004 3.7L 2WD Limited.

Driving fine then started to sputter and had really bad smoke out of the tail pipe. Towed to my mechanic. He's tried a new fuel pump, blew the lines, checked fuel pressure. Has 60 PSI when car does turn on and when off PSI is 0. Did new injectors, new spark plugs and coils, and new injector rails. All still having the same problem of fuel dumping and difficulty running.

I am now convinced, and mentioned to the mechanic, that its computer related. My wife researched and thinks its the PCM and I'm inclined to agree with her. But I wanted to throw this out to everyone as well. Everyone in this forum seems to be super helpful.
 

Ksat

Full Access Member
Joined
Nov 11, 2018
Messages
154
Reaction score
65
Location
ny
What color is the smoke? Do you know why your mechanic put a new pump in? Scan the PCM for codes also see what fuel trims are.
 

Latest posts

Members online

Top