HOW TO: Install an EVIC or OTIS (overhead computer)

Discussion in 'How To' started by Bennett, Dec 10, 2004.

  1. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ok, I think I'm ok - ok not great, but ok.
    Looking closer at the Ebay EVIC pictures I see the connectors for the lights AND the EVIC with small stubs of wire out of each. Maybe just enough for me to solder 4 wire trailer wiring to.

    And according to the "Installing an OTIS" how to web page it's the latest EVIC #56042756AJ

    s-l500.jpg
     
  2. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Dag nab it - so the console retainer bracket p/n 5072348AA I order online, came back as cancelled order due to discontinued part.
    So I guess my search for another console retainer bracket p/n 5072348AA is back on.


    .
     
  3. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Please Help identify correct part

    Ok, I went to my local auto wreckers and they came back with this (see below link for pictures).....

    I'm not 100% sure - they said it came out of a Cherokee.

    Is this what the retainer bracket is supposed to look like ? The numbers on it don't look like the p/n number I got from the threads here...
    Please advise?
    https://photos.app.goo.gl/5pxbjDhWszisXY1G8


    .
     
  4. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    If that is the correct retainer bracket (I'll know for sure when my EVIC from EBAY arrives, I suppose) how has the 3m tape method work out in the long run through hot & cold temps for you guys?
    If not someone suggested to me to use E6000 glue.....
     
  5. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Hello
    If anyone is interested I posted this thread EVIC dont show ambient temperature, only dashes "_ _" , to concentrate all the info in just one single and short post to try to get the Instant MPG along with TPMS and Homelink of course, in a 2004 Jeep Liberty and probably later years.

    Any help is appreciate it !!
     
  6. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Can anyone HELP!

    ‚ÄčOk I thought I had everything figured out and got all my necessary parts. I finally had some time to do this mod. First thing stopped me in my tracks - that is that the dome courtesy light plug / wiring is totally different in my 05 Liberty than the EVIC (56042756AJ) I got from Ebay. I'm going cross eyed from all of the 40+ pages from the HOW TO: Install an EVIC thread - I can't find the wiring difference and /or solution to this. Can anyone HELP!

    see link for pictures dome courtesy light plug / wiring differences

    https://photos.app.goo.gl/iPu1Z4SYpL8RpCTD6


    .
     
  7. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I figured out/found the courtesy dome light plug wiring and lights working backwards dilemma from post #96 & #97. Now I just have to figure out how to change/move the wiring within the plug.

    As I mentioned last night I hook up the EVIC and powered it up briefly. I did not cut the head linener/mount it yet - the no turning back portion, until I was sure everything is working. All seems to be working except the Temperature reads --F .
    The EVIC I got is from a 2004 GC, which reading here, multiple times, says an 04 or newer EVIC will work for my 05 Liberty temp reading to work. I do have a temp sensor installed, even purchased an additional new one, same result. Some say it might just need to register different temps for more than 5 min. I have the Liberty still in my garage as I'm working on other things, so I haven't kept it on longer than 5 min.
    I have a few other issues like only one tire is not reading pressure, but the other three show 33,33,32 , I didn't even think I had TPMS sensors in ths tires?..?..?. Also only the front drivers and front passengers door register open/closed, not the any of the rear doors or glass/gate, but still does show on the dash.

    See pics - I used tap a fuse on #13 fuse position, and the OBD adapter worked out nice , hope the cutting of the headliner comes out as well..
    https://photos.app.goo.gl/URTiTA7KL2sDZ93C6


    -TC
    _______
    [_] [___]
    l-----{o||||o}
    ()_) ()_)-o-)_)

    "Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the present." -Master Oogway (KungFu Panda)
     
  8. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    I now had the Liberty out in the driveway running longer than 5 min. STILL NO TEMP. reading.
    Does this mean I NEED AN EVIC FROM AN 05 OR HIGHER.... ?

    .
     
  9. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    I have read somewhere in this post that must be a 2004+ Liberty to work the temperature reading, but can not be from a GC.
    No Idea if it is true or not.

    I still need to figure out the "_ _ " temp thing but no one has replied to my post yet, I guess these jeeps are too old.
     
  10. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Thanx, yes I believe that is both our problems. So we need an EVIC out of an 04, or 05 to 07 LIBERTY specifically?
    I have an Ebay seller who has a few andrelized that, and is asking the part number - he recalls the Liberty's EVIC having a bit different part number from a previous transaction. ..

    Does anyone know what the part number(s) would be for an 04, 05, 06 ,or 06 for an EVIC specifically from a Liberty?

    .
     
  11. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Make it easier, ask the seller what part numbers he has and then search them in Ebay, it will show probably.
     
  12. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    And if dont mind please share them, I have a few, that I also read many pages ago.
    Ebay shows them as for Liberties
     
  13. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    The Ebay ads may show "FOR " Liberty's, but that doesn't mean it came out of a Liberty! That's what I'm finding out.

    Now to add to my EVIC issues - besides the -- F for the temp. I now noticed all of a sudden when the kids get in the back (open both rear doors) only the right rear started showing open and never clears (shows closed) when the doors are closed. I have to unplug the EVIC to get it to stop showing - only until my daughter opens the right rear door again.
    I'm leaving this EVIC DISCONNECTED and going back to just the map courtesy lights until I find the PROPER EVIC ....

    .
     
  14. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Ebay seller mentioned this;

    The last numbers 57aj or 49aj the 56 is tps but I know the liberty has the first half of the number is different..

    Any help/ idea of the Liberty part number?

    .
     
  15. Chungungo

    Chungungo Full Access Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 31, 2018
    Location:
    Chile
    Try this 56010438AD
     
  16. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Got another EVIC (from 05 Liberty) wires different coloring

    I just found another EVIC at a wreckers out East of me - they say it's from an 05 Liberty part number P/N 56010520AD...

    I see that the wire colors for the EVIC plug are different and the Courtesy Dome light plug is the same as in my 05 Liberty, which is a plus (I wont have to mess with that wiring)...

    Now I'm wondering if the way I wired my wiring from the Jeep Grand Cherokee WJ - Overhead console and EVIC and Installing an OTIS How To install an EVIC is going to work?
    The say :
    EVIC pin #5 Blue / White to fused ignition switch Output (#13 fuse block)
    EVIC pin #4 Black/Orange to pin #4 of the OBD port > GROUND
    EVIC pin#3 Pink to pin #16 of the OBD port > FUSED B (+)
    EVIC pin#2 Yellow/Violet to pin #2 of the OBD port > PCI BUS

    Where as this (05 Liberty) EVCI plug has:
    EVIC pin#5 Pink / Green
    EVIC pin# 4 Black/White
    EVIC pin# 3 Red
    EVIC pin# 2 White Violet

    See Pictures:
    https://photos.app.goo.gl/9itUksTtsjE9Bzck7



    .
     
  17. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    IF the pins/functions to the EVIC are all be the same ( ? )

    If so then the color code of the wiring does NOT matter as long as the pins/function at the EVIC are the SAME....???....????

    Can anyone Confirm this for me ?

    .
     
  18. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Found it -I missed the note that says "WIRE COLORS MAY VARY"


    .
     
  19. Mytmouse

    Mytmouse Full Access Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Dec 19, 2018
    Location:
    New York
    Wait am I reading this correctly - that if this is an 05 EVIC to get the TPMS to work, it is not just a matter of getting 4 (or 5) tpms sensors and a Retraining magnet ?
    That the 05 that came with TPMS as an option has a different set up - external antenna's in each wheel well?
    .
     
  20. Kal-El

    Kal-El Full Access Member

    Messages:
    538
    Likes Received:
    6
    Joined:
    Dec 19, 2015
    Location:
    Glendale, Arizona
    It's been a while since I've messed with EVICS....but if I recall correctly....if your EVIC has the TPMS option, not installing the wheel sensors will result in a very annoying chime and a display that constantly reminds you of a "bad or missing sensor".