45rfe rough shift help

Discussion in 'KJ General Discussion' started by Jbergun, Oct 19, 2015.

  1. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    So yesterday i noticed the jeep shifting funny around 20-25mph. When i stay on the gas the shift feels slow. Takes maybe 2-3 seconds. In this time it doesnt make any noise or grinding just waits asec then shifts. Being that i live in the city there are times i ease off or totally let go of the gas right around this speed before the shift. When i do this it hits hard and makes some noises not grinding just like a click and a thump. So this morning started just fine let her warm a few minutes hit the road shifting fine throughout the gears. Drove on the highway for about 15minutes and when i got off the highway it started. Yesterday after the long drive it started doing it i stopped at dunkin for coffee and the jeep sat a few minutes running and then was shifting normal. I dropped my pan and did the filters a few months back and replaced the atf4+. Took a little time to get the level right but i got it good when its hot its at the hot line. I am worried i dont exactly have money to be throwing at it. Fluid looks good level looks normal. What can i do what are my options should i continue driving her.
     
    Last edited: Oct 19, 2015
  2. M38 Bob

    M38 Bob Full Access Member

    Messages:
    1,072
    Likes Received:
    1
    Joined:
    Jun 23, 2015
    Location:
    Arkansas
  3. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    It does shudder in the morning when i put it in drive. I dont know if that information dictates a specific problem. After i let it warm up a minute or two i put it into drive and as i let go of the brake and go for the gas almost wants to die but never does.
     
  4. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Just ran her idling up to temp shifted from park to drive n reverse a few times. Checked the dip stick the fluid has bubbles in it. Cleaned it dipped it in again same bubbles on the stick. Whats this mean?
     
  5. uss2defiant

    uss2defiant Full Access Member

    Messages:
    3,296
    Likes Received:
    15
    Joined:
    Jun 25, 2014
    Location:
    Tucson, Arizona
    I think Tim has tried Lubeguard.

    So did you check the fluid level when jeep is at temp. and in neutral?
     
  6. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Yea that was in neutral at temp fluid has bubbles and maybe a little high
     
  7. mx3_ryder

    mx3_ryder Full Access Member

    Messages:
    351
    Likes Received:
    0
    Joined:
    Jan 27, 2014
    Location:
    troy VT
  8. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    So my best guess is the fluid is a little high. I am guess thats causing the bubbles i drained out about 6oz. Still seemed on the higher side but shifted better but i could only take it around the block. Real test is after work. My question is what damage could have been done? My guess is it wasnt giving me problems before because it was hot outside now the temp is changing its thicker.
     
  9. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    So this was before i drained anything in neutral.

    [​IMG]

    [​IMG]

    Now this is after i had drained 6oz and ran it around the block similar temp maybe warmer.

    [​IMG]
     
  10. uss2defiant

    uss2defiant Full Access Member

    Messages:
    3,296
    Likes Received:
    15
    Joined:
    Jun 25, 2014
    Location:
    Tucson, Arizona
    Sorry. I'm not an expert here so I don't know whether it's an issue.
    either overfilled or something is aerating your fluid.

    There's a chart in the FSM that gives you fluid level versus temperature of the tranny.

    Do you have a thermocouple probe you could slide through the dipstick funnel to measure the tranny temperature?
     
  11. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    No i dont i think i may have to take it into a trans shop have them hook up the reader. Yesterday when i checked the fluid before any of this happened there were no bubbles. Now bubbles i have no idea what went wrong.
     
  12. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    So i took out about 16oz of fluid looks level now still some bubbles. But they may just be settling down. Hope my ride home is smooth will chime in after. About 2 hours from now. Thanks for your input guys i need every bit of help i can get.
     
  13. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,445
    Likes Received:
    68
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Any update? I have the 45rfe and have serviced the tranny several times over the years. Never overfilled or noticed any bubbling, but I did have a 93 Grand Am a while back and the tranny fluid would foam like you showed when I overfilled just a little bit. It would shift weird too. Had a heck of a time getting the level right in that thing. Never seemed to cause any problems. Got rid of it when I got my KJ. Actually donated it to charity. That was a pretty tough little car.
     
  14. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Got the level right still shifting odd. If i keep its at about 20% throttle just a stall and shift. At about 40% throttle ahifts almost normal. Tried with overdrive off no different maybe even a little rougher. No bubbles once i got home. Fluid is right at the bottom hot dot.
     
  15. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,445
    Likes Received:
    68
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Sounds kinda like what mine does with the overdrive off. Like it won't downshift until it feels like it's about to stall when you hit an incline. Lugging away! If you give it enough gas then it'll downshift hard. It's shifted like that with OD off as long as I've had it. Drives me nuts since I prefer to not have OD on except on the highway. All is well when OD is on.
     
  16. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Na mine is bad in both. I am going to disconnect my battery and let it sit a while tomorrow reset some shit hope it helps. Just sucks. I dont have any codes i dont have and metal in the atf i took out. Its looks fine smells fine. I drive gingerly never beating her up. I cant get a trans i might have to ride it out.
     
  17. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    So problem still persists. This morning i was hopeful that it was gone shifted fine all the way to the highway. Once i exited the highway i noticed it shifting. My best explanation to how it feel is if you were hitting the gas everyone know the force you feel pulling you back in your seat then when it goes to shift its like you hit the brakes for a second and went back to the gas. It feels like a slow shift on a manual transmission i guess. I read somewhere it could be an actuator spring read somewhere else it could be the speed sensors. Any input would help.
    As i said before all other shifts are fine. Fluid level is good no more bubbles.
     
  18. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Would my transfer case have anything to do with this. I havnt gotten around to draining and filling that yet.
     
  19. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Disconnected the battery for an hour and a half going for a test drive on lunch see what happens. Will report back.
     
  20. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Still there. Someone said put the lucas slip and hard shift stop gonna have to try that.