Engine problems

Discussion in 'KJ General Discussion' started by jdamanthey, May 3, 2005.

  1. Kjoy

    Kjoy New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 5, 2005
    Mine has 82K on it and have had no problems what so ever. The only minor thing I had was the transmission acting funny after I installed the offroad tires. Other than that, it runs like a dream.
     
  2. mudtrackerinc

    mudtrackerinc New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    May 15, 2006
    Location:
    Indiana
    I'm actually having a similair problem right now, I just bought a 2002 with the 3.7, I had it 9 days and had to have it towed back to the dealer, today marks the 12th day that they have had it. Currently they are telling me that the rocker arm came off and went through the cam. They sent the head out to the machine shop to be tested, and while it tested fine, the guy at the machine shop told them that he had a few others just like this one, and if they put that same head back on, it would only do it again. Right now I guess they are waiting for the new head to come in. This has all happened at 45,000 miles. Lucky for me I guess is the fact that it was still under that 3 month warranty and I did elect for an extended one also. Of course the dealer is being a complete butt right now, because I had only had it 9 days, I think that there should be a little more quickness in there step, they told me Thursday that they had ordered the head and would probably get it by Wednesday this week, I said, "Ever heard of Fed Ex?" Hopefully you are dealing with a better dealer than I am. Good luck, I'd like to know what they finally figure out with yours though.
     
  3. sprsonic

    sprsonic Full Access Member

    Messages:
    120
    Likes Received:
    0
    Joined:
    Feb 7, 2006
    Location:
    toledo ohio
    hope you guys know that midway through 2002 depending on date there was a thing called 7/70 powertrain warranty coverage. 100.00 deductible. that would be covered. and there is an updated valve spring. recently had a valve spring break and valve hit piston, luckily customer only ruined cylinder head. bent exhaust valve and just left the valve imprint on top of the slug. anyone w/this problem should replace all valve springs on earlier 3.7 engines before any further damage occurs. if roller followers just pop off and no damage occurs just means the springs are weak(my recomendations)
     
  4. 2003KJ

    2003KJ Member

    Messages:
    5,323
    Likes Received:
    6
    Joined:
    Sep 13, 2004
    Location:
    Planet Earth
    boy this sure is an interesting thread. So it seems that the problems are mainly on the first half of the 02 models?
     
  5. sprsonic

    sprsonic Full Access Member

    Messages:
    120
    Likes Received:
    0
    Joined:
    Feb 7, 2006
    Location:
    toledo ohio
    all of the 3.7 libbies that i've had engine problems with have been 02's. sorry i had 1 03 w/2 miles that had a broken piston ring and cracked the piston.
     
  6. mudtrackerinc

    mudtrackerinc New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    May 15, 2006
    Location:
    Indiana
    Thanks for that heads up. Currently I am still waiting on the head to be shipped. Supposedly it was on back order (read they just hadn't ordered it yet) and is supposed to be in tomorrow. The guy told me, if they can get my Jeep in the bay on Thursday, I might have it back by Friday. I of course replied with, I'd better have it back by Friday.
     
  7. mudtrackerinc

    mudtrackerinc New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    May 15, 2006
    Location:
    Indiana
    I was just wondering what happened with your engine? They replaced the head on mine, had it back a week and a half, less than 200 miles later, it's in the shop again. Anyone have anything?
     
  8. sprsonic

    sprsonic Full Access Member

    Messages:
    120
    Likes Received:
    0
    Joined:
    Feb 7, 2006
    Location:
    toledo ohio
    if you are refering to my last post. these were not my personal vehicles, they were customers. i was just repairing them.
     
  9. mudtrackerinc

    mudtrackerinc New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    May 15, 2006
    Location:
    Indiana
    Any ideas on what they should do with mine then? I at least have a rental now, but no idea what they are going to do to fix it yet, they say they are waiting on word from Chrysler.
     
  10. sprsonic

    sprsonic Full Access Member

    Messages:
    120
    Likes Received:
    0
    Joined:
    Feb 7, 2006
    Location:
    toledo ohio
    check your pm's
     
  11. oldcarguy

    oldcarguy New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Nov 29, 2007
    Location:
    North Carolina
    Rocker arm falling off on 3.7L

    My son has a rocker arm on #4 that keeps falling off. I replaced it several months ago along with the lash adjuster. The coolent is also slowly going away. Oil is clean no excessive smoke at the exhaust. Cylinder leakdown test is good. Valve spring is good. Engine has 130K miles on it. This weekend I plan on pulling the head and replace the head gasket. I can't think of anything else. I plan to mic the cam lobe too to check for wear. Anyone else had a similar issue. Any other ideas? I am not real fond of this engine!! I love the old 4.0L inline 6.
     
  12. oldcarguy

    oldcarguy New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Nov 29, 2007
    Location:
    North Carolina
    Just read the rest of the thread. Looks like I have a damaged head or valve seat. OH crap!! Big Bucks!
     
  13. JIMMY JEEP

    JIMMY JEEP Full Access Member

    Messages:
    371
    Likes Received:
    0
    Joined:
    Jul 15, 2007
    Location:
    United Kingdom
    Head gasket problems are common on modern engines ,more alloy used in heads ect and engines run hotter to burn more efficientley to pass strict emmision standards.Some makes are more prone than others but there has definatley been an increase in recent years.
     
  14. DougBenn

    DougBenn Full Access Member

    Messages:
    487
    Likes Received:
    0
    Joined:
    Dec 4, 2005
    Good luck, I had one of my 05 Libby's with a very similar problem. I honestly believe from experience and talking to the dealer that Jeep has a serious problem with the 3.7 valve train. Not sure I will be keeping my other Libby now.

    The other one I got DC to do a buy back on after all of the problems.

    I had planned on keeping this one to give to my youngest daughter in 3 years. Not feeling good about that any more.
     
  15. JeepJeepster

    JeepJeepster Full Access Member

    Messages:
    8,412
    Likes Received:
    8
    Joined:
    Dec 15, 2004
    Location:
    Dem hollers in Ky
    The 3.7 does not have valve train problems. They have made over a million 3.7L's so you would hear about it alot more if they did have issues.
     
  16. DougBenn

    DougBenn Full Access Member

    Messages:
    487
    Likes Received:
    0
    Joined:
    Dec 4, 2005
    I still disagree with you as I have experienced this as well as several others just at my dealership. I am sure this is not a "regional" failure just in my area.

    I am not saying they are all bad I suppose but the likelyhood that you will have a problem with bad valve springs, retainers, valve seats etc seems pretty good.
     
  17. oldcarguy

    oldcarguy New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Nov 29, 2007
    Location:
    North Carolina
    Follow Up on Rocker Arm falling off

    Just wanted to give you an update on problem of the #4 exhaust rocker arm falling off on cold start. The problem seems to be caused by the engine being gummed up. I took the heads to the machine shop and the seats and spring pressures were good. I think the restricted oil flow was causing the lash adjuster not to pump up properly and allowed the rocker to fall off since there is nothing but spring pressure to hold it on. The oil pump screen was partially blocked by sludge. I am doing a complete tear down and cleaning of the engine. The oil was changed regularly and synthetic blend was used. I think it is from around town short trip and the engine does not get hot enough to burn off the combustion by products that normaly blow past the rings

    oilscreen2.jpg
     
  18. JeepJeepster

    JeepJeepster Full Access Member

    Messages:
    8,412
    Likes Received:
    8
    Joined:
    Dec 15, 2004
    Location:
    Dem hollers in Ky
    Glad to hear that it wasnt valve train issues.

    What brand oil did you use? I cant believe it has that much sludge in it.
     
  19. 2003KJ

    2003KJ Member

    Messages:
    5,323
    Likes Received:
    6
    Joined:
    Sep 13, 2004
    Location:
    Planet Earth
    I do not like the looks of that one bit....

    Please do tell what oil you're running, average trips (how short or long)...etc etc.

    If you could take some more pictures as you go along your tear down and post them up that would be awesome!
     
  20. Ry' N Jen

    Ry' N Jen Banned

    Messages:
    9,247
    Likes Received:
    3
    Joined:
    Dec 26, 2006
    Location:
    Slightly North of the 49° th. Parallel... In HongC
    We have 146 500 kilometer or 91 030.80 mile on the clock with our 3.7 liter. with no problems what so ever.
    The engine feels new and tight with loads of torque off the line and awesome passing power.