2007 2.8L KJ Jeep Cherokee ETC light no codes

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Burgermccartney

New Member
Joined
Apr 2, 2022
Messages
3
Reaction score
1
I have a 2007 2.8L CRD which had a RAM fault code and was in limp mode. I've replaced the TCM which fixed the limp mode and no more DTCs. But it still has the ETC light flashing with no fault codes logged and no noticeable symptoms. I think it had this light flashing before the TCM fault so might not be related. Any ideas?
 

tommudd

Moderator
Staff member
Moderator
Joined
Jul 14, 2005
Messages
22,456
Reaction score
3,635
Location
Southeastern Ohio
Pull the battery cables and hook / tie them together for 15 to 20 minutes, reattach and then see what happens .
Sometimes codes set and no matter what they wont leave until you do a reset
Let us know , others may have other ideas
 

Quercy

New Member
Joined
Jan 29, 2024
Messages
4
Reaction score
1
I have a 2007 2.8L CRD which had a RAM fault code and was in limp mode. I've replaced the TCM which fixed the limp mode and no more DTCs. But it still has the ETC light flashing with no fault codes logged and no noticeable symptoms. I think it had this light flashing before the TCM fault so might not be related. Any ideas?
 

Quercy

New Member
Joined
Jan 29, 2024
Messages
4
Reaction score
1
Hi
I have the same vintage Cherokee with the same flashing etc light and no fault code. Did you find a fix because I am at my wits end.
Many thanks
Quercy
I have a 2007 2.8L CRD which had a RAM fault code and was in limp mode. I've replaced the TCM which fixed the limp mode and no more DTCs. But it still has the ETC light flashing with no fault codes logged and no noticeable symptoms. I think it had this light flashing before the TCM fault so might not be related. Any ideas?
 

Quercy

New Member
Joined
Jan 29, 2024
Messages
4
Reaction score
1
I have a 2007 2.8L CRD which had a RAM fault code and was in limp mode. I've replaced the TCM which fixed the limp mode and no more DTCs. But it still has the ETC light flashing with no fault codes logged and no noticeable symptoms. I think it had this light flashing before the TCM fault so might not be related. Any ideas?
 

KJowner

Full Access Member
Joined
Oct 20, 2022
Messages
748
Reaction score
428
Location
Uk
Did you try the reset above? Also try a new Battery or get your tested.
Could be faulty ECU (or PCM as Jeep call it!) I'd get it tested by a specialist if the reset and fresh battery don't help.
 

KJowner

Full Access Member
Joined
Oct 20, 2022
Messages
748
Reaction score
428
Location
Uk
Oh, hang on, you have tacked your fault onto an old post! Do you have a RAM fault or just ETC?
 

Quercy

New Member
Joined
Jan 29, 2024
Messages
4
Reaction score
1
Did you try the reset above? Also try a new Battery or get your tested.
Could be faulty ECU (or PCM as Jeep call it!) I'd get it tested by a specialist if the reset and fresh battery don't help.
Thanks for your reply. I am living in France and since the Fiat takeover, all the dealerships have changed and the new dealers are only interested in the current vehicles.I have taken the car to a local auto electrician who diagnosed a faulty battery but the change has made no difference. On a positive note, once the engine is at normal temperature, if I stop and restart, the fault disappears. For the bi-yearly 'controle technique',I arrive at the testing station with a hot engine and it passes. Many thank for your help. Quercy
 

Latest posts

Members online

No members online now.
Top