Tire pressure light

Discussion in 'Technical Service Bulletins and Recalls' started by beinroc, Jan 5, 2010.

  1. beinroc

    beinroc New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Aug 14, 2009
    Location:
    Lancaster, PA
    '06 Liberty Renegade. tire pressure light comes on even after i fill tires with air. Did that a few times now it flashes for a few seconds, then goes off. Repeats the flashing regularly. tires are all brand new. 4 months old. Car only has 30k miles. Anyone have any ideas? Seems a lot of lights come on in this vehicle. anyone also ever heard of any problems with the ECM being bad? As i said, only 30k miles. Thanks.
     
  2. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,605
    Likes Received:
    31
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    I'm thinking that the shop that replaced the tires damaged a sensor in one of the wheels. If not that, it could related to the ECM issue....
     
  3. maverick7321

    maverick7321 Full Access Member

    Messages:
    220
    Likes Received:
    0
    Joined:
    Mar 13, 2008
    Location:
    Georgia
    Have you checked the air pressure in the spare for I chased this same thing for months and finally found that it was the spare tire that was low on air.
     
  4. beinroc

    beinroc New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Aug 14, 2009
    Location:
    Lancaster, PA
    i did not check the spare tire as of yet. I guess that will be the next step. i don't think they damaged a sensor cause this just started happening about 2-3 weeks ago. Really when it started getting under 20 degrees outside. I even jacked all the pressures up to 42 psi. i did find one tire at 33 psi so if the spare isn't it, i guess i need to have that one checked for leakage. thanks guys.

    beinroc
     
  5. Dave08

    Dave08 Full Access Member

    Messages:
    58
    Likes Received:
    0
    Joined:
    Mar 26, 2008
    Location:
    Omaha
    one of mine does it when really cold for a second on start up
     
  6. Nathaniel

    Nathaniel New Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    May 17, 2009
    Location:
    So. Maryland
    i have the same problem, dude. Mine came on as soon as i bought the jeep. then months down the road i got a flat.. After that it went off for a long time, and now its back on, i know i need the air in my tires, but if that doesnt work i may need to get a censor checked.
     
  7. baer jeeper

    baer jeeper Full Access Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jun 9, 2012
    Location:
    winnipeg,Manitoba, Canada
    had the same problem replaced the sensor apparently the battery get week? lights stayed out for two weeks so far