Some issues with transmission...looking for thoughts

slingworks

New Member
Joined
Jul 6, 2021
Messages
1
Reaction score
0
Ok, I have a typical, or non typical trans issue going on today.

I have a 2005 RHD Jeep Liberty 3.7 4x4 with approx 330k miles that has developed some trans issues that perplex me.

I've worked on this jeep quite a bit over the years, including replacing the shift solenoid pack and selector switch about a year ago. Fluid is clean looking good. The jeep shifts from 1st to 2nd rather abrupt, and then stays in 2nd not downshifting. The code P0700 is displayed. I'm looking for possibilities here, i don't believe the shift solenoid is faulty...
2 years ago the trans was fully rebuilt by a very reputable shop and up to this point worked flawlessly.

I also had some issues with it stalling out in reverse the prior couple weeks if I applied any amount of throttle, But seemed to have fixed it for now. (wires were worn out missing insulation and touching at camshaft sensor).

I do have one small thought, maybe someone here can verify? I had boxes against the shift selector pressing on the overdrive button for extended periods of time. If the button is held down continuously, would it have an effect on the TCM?
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,378
Reaction score
1,015
Location
B.C. Canada
Welcome to the forums.
As you may know the 42RLE transmission shifting is very much electronically controlled.
The 700 code is somewhat generic and there may be other associated codes along with it. Get it re-scanned by trans shop.
The torque converter, was it replaced when the re-built was done?
Good that you are checking wiring.
Get rid of boxes touching OD button, you want OD available.
OD button off will cause the jeep to rev higher for sure, not good at hwy speeds.
 
Top