Rear wiper won't park.

mikn67

New Member
Joined
Sep 20, 2021
Messages
2
Reaction score
0
Hey. Great board. I appreciate all the helpful insight you all share here. I’ve had my 2012 Liberty Jet edition for about a year. In that time, I’ve had to replace the shocks and struts, and I just replaced the starter; I have a random misfire issue when starting the engine; it's only happened twice. But I’ve also discovered a handful of minor annoyances. One of which I'm sure is the master switch because my wipers will sweep when I use the turn signal occasionally. The one that baffles me is my rear wiper. I’ll turn it on for one sweep to clear the glass; it acts like it's about to park, then comes on for 5-10 sweeps before it decides it's done. Master switch too? What are your thoughts?
 

tommudd

Moderator
Staff member
Moderator
Joined
Jul 14, 2005
Messages
21,641
Reaction score
2,808
Location
Southeastern Ohio
Sounds like you need new switches
Do you turn the rear clear off
One KJ I was working on for a friend would do one sweep, little while later do it again, I guess it had been doing it for a month, here he never shut it clear off LOL
As far as shocks, we don't have struts, should of replaced springs as well since old sagged springs will wear out shocks faster , makes them work twice as hard so will wear out in a year or so
Misfire could be as simple as bad gas
But when was the last time you changed spark plugs, on these every 30,000 miles you need a new set of NGK Copper plugs ( use these only )
Those will cause a miss every now and again or when using the wrong plugs
 

mikn67

New Member
Joined
Sep 20, 2021
Messages
2
Reaction score
0
Sounds like you need new switches
Do you turn the rear clear off
One KJ I was working on for a friend would do one sweep, little while later do it again, I guess it had been doing it for a month, here he never shut it clear off LOL
As far as shocks, we don't have struts, should of replaced springs as well since old sagged springs will wear out shocks faster , makes them work twice as hard so will wear out in a year or so
Misfire could be as simple as bad gas
But when was the last time you changed spark plugs, on these every 30,000 miles you need a new set of NGK Copper plugs ( use these only )
Those will cause a miss every now and again or when using the wrong plugs
Thanks. Yes, it has two settings. Delay and off. I just do a quick turn on then off. I’m no mechanic but, my gut tells me there is a bad sensor on the wiper motor itself.
Regarding the plugs, I’m getting ready to change them and the ignition packs to.
Master switch may have to wait for another day.
 

Jeremy-WI

Full Access Member
Joined
May 20, 2017
Messages
270
Reaction score
74
Location
Home
Might want to watch this video,
xc_hide_links_from_guests_guests_error_hide_media
at about 9 minutes it shows some contacts inside that likely control if/where the wiper parks. Looks like a new motor assembly is about $50 and up
 
Top