Possible Trans Issue

Discussion in 'KJ General Discussion' started by Tru, Jan 23, 2011.

  1. Tru

    Tru New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jan 23, 2011
    Location:
    Georgia
    :disgust:

    2005 Jeep Liberty
    2X4 V6 3.7L
    130,000 Miles

    Like to start off saying that this is a PRETTY COOL SITE and luv that everyone knows there stuff on the Libbys and all!!!

    Now to my dilemma....

    Today while driving to work on the freeway at about 60 to 65 MPH, i hear/feel a big JOLT/PULL BACK sort of a rev down type a feel on my Liberty. I immediately put it on neutral and pulled off to the side road. Exited the freeway off the ramp to the main street on momentum. As I tried to get the Liberty back on D it will not take the gear. All it does is rev and that is in all gears D,1 and 2. I tried shutting truck off and on and still nothing. The engine runs fine its that the trans will not gear up. Please don't say that the trans already went bye-bye on me, I bought the truck used just 2 months ago. Just last week I felt a very minor jolt but didn't think anything of it. Whats funny is that after I'd stopped and restarted it, the truck would not moved on neutral, it seemed to stay stuck as if the car was locked in park. However to push it to the side I had to place the shifter on Park while the ignition is semi on... WEIRD!!!!
    Question-
    Could this have been what the POWER TRAIN:AUTOMATIC TRANSMISSION recall is referring about?

    Anyone's advice will be DEEPLY appreciated!!! :shrug:
     
    Last edited: Jan 23, 2011
  2. LibertyGuy

    LibertyGuy New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Aug 27, 2010
    Location:
    Hockey Country
    Welcome!

    Sorry to hear about your troubles, did you have it towed to a Jeep dealer? If so, what did they say?
     
  3. JeepJeepster

    JeepJeepster Full Access Member

    Messages:
    8,415
    Likes Received:
    10
    Joined:
    Dec 15, 2004
    Location:
    Dem hollers in Ky
    Good place to start is checking the tranny fluid.
     
  4. 04Liberty

    04Liberty Full Access Member

    Messages:
    1,189
    Likes Received:
    9
    Joined:
    Sep 14, 2006
    Location:
    MD
    Do you still have a driveshaft?
     
  5. Tru

    Tru New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jan 23, 2011
    Location:
    Georgia
    To scared ($$$$) to take it to the dealer.... So i took it to a friend that works from home on the weekends.. Told me that the transmission is SHOT! :(

    Says that when he puts its on reverse it make a LOUD SCREECHING noise, but still it wont budge! Now out to look for a tranny.

    Question.. how can i determine the type of tranny to replace it with since I now have to shop around for one? Will a 4X4 automatic tranny fit the 2x4? Where is a go source to read about the differences?
     
  6. yellocoyote

    yellocoyote Administrator

    Messages:
    7,202
    Likes Received:
    10
    Joined:
    May 14, 2008
    If you have to replace the transmission, your year KJ calls for the 42RLE tranny.

    But, as said above. Try changing out your fluids or taking it to the dealer. Work through some of the less expensive options before giving it up for dead.
     
  7. Tru

    Tru New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jan 23, 2011
    Location:
    Georgia
    yellocoyote, how would i know if its a 3 plug or 4 plug connector...? while shopping around they ask me that.
     
  8. dentwizz

    dentwizz Full Access Member

    Messages:
    86
    Likes Received:
    0
    Joined:
    Jul 7, 2009
    Location:
    Strasburg, PA
    It almost sounds like an electrical issue. Correct me if I am wrong, but the auto trans uses electronic solenoids to shift/clutch? One of my coworkers went through a similar symptom for a couple months, dealer trips and all(under warranty anyway) on a GMC/Allison trans. It ended up being the computer in the trans confusing the shift points to engage simultaneously. He only had 50k on it.