new member... 1st question.

Discussion in 'KJ General Discussion' started by rockymountain, May 2, 2007.

  1. rockymountain

    rockymountain Full Access Member

    Messages:
    1,709
    Likes Received:
    0
    Joined:
    Apr 20, 2007
    Location:
    Spencerville, IN
    I have graduated myself I guess to an 04 from an 03. Just joined this site not too long ago. I bought a hard to find one in my opinion. I got an 04 Rocky Mountain Edition. 3200 miles on it. Yes, that is NOT a typo. Not sure of the story behind it, but the dealer I bought it from got it right from DC. Anyway, here is my first question (for the new 04). My 03 has the little green lights on the lock switches and on the mirror controls. My 04 doesn't. Rather it does, but seems they are not coming on. I couldn't find anything in the manual about a fuse for these, so I am stumped. Does it have them or not? Thanks!!!
     
    Last edited: May 2, 2007
  2. rebelram

    rebelram Full Access Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jan 5, 2007
    Location:
    HSV, Alabama
    The switches are setup for the little green lights, but they do not illuminate. I was curious about the same thing on my 06 when I first got it because I had been in various other Mopar products that had the same switches and they did illuminate. Just another case of cost cutting and taking shortcuts.

    Something interesting I did notice on my 06, the front two window switches are marked AUTO for the one touch auto-down feature. The white letters AUTO seem to be some sort of glow in the dark paint because they do glow at night and it has nothing to do with whether the lights or ignition are on.
     
  3. indianrefining

    indianrefining Full Access Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Oct 11, 2005
    Location:
    Columbus, Indiana
    You must both have glitches of some sort. I've had an '03, and '05, and now have an '07, and the lights have worked just fine on all three of them.
     
  4. Gentleman

    Gentleman Full Access Member

    Messages:
    406
    Likes Received:
    0
    Joined:
    May 26, 2005
    Location:
    8' Below Sea Level
    They have never illuminated on my 05

    Bob
     
  5. 2003KJ

    2003KJ Member

    Messages:
    5,323
    Likes Received:
    6
    Joined:
    Sep 13, 2004
    Location:
    Planet Earth
    Pretty sure the illuminate on my 03 as well.....and I seem to recall this coming up in another discussion some time ago....i'll have to see if I can dig that up.
     
  6. joeg

    joeg Full Access Member

    Messages:
    120
    Likes Received:
    0
    Joined:
    Feb 6, 2007
    Location:
    Lorain, Oh
    My 06 ?? No lights
     
  7. JeepJeepster

    JeepJeepster Full Access Member

    Messages:
    8,406
    Likes Received:
    5
    Joined:
    Dec 15, 2004
    Location:
    Dem hollers in Ky
    Probably just a cost cut for DC. My 04 has never had them. The only buttons that light up are the switches in the rear for the windows and the switches for the front windows.
     
  8. K Dje Ryu

    K Dje Ryu Full Access Member

    Messages:
    269
    Likes Received:
    0
    Joined:
    Mar 6, 2007
    Location:
    Casper, Wyoming
    I've never noticed any of my window switches being lit on my 05