Mysterious Misfire

Discussion in 'KJ General Discussion' started by cmontel727, Mar 15, 2013.

  1. cmontel727

    cmontel727 New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    Location:
    Newton, NJ
    I am currently struggling with a misfire on #6 cylinder. The usually happens once or twice a week on a cold start. The engine will run rough, obviously missing. If I shut off the engine and restart the miss will go away.

    The computer is throwing a code of P0306, I have replaced the spark plugs and swapped over coil packs. Still getting the miss on the #6 cylinder.

    I am wondering what to check out next. Could it be an injector issue, there is a strong fuel smell raw fuel out of the exhaust?

    (2002 Liberty Sport 6 cylinder - 102,000 miles)

    Any suggestions would be welcome!

    Thanks
     
  2. 1BADKJ

    1BADKJ Full Access Member

    Messages:
    502
    Likes Received:
    1
    Joined:
    Feb 18, 2012
    Location:
    Barnegat NJ
    If you moved the coil and it didn't follow it then move the plug also. If it still doesn't follow it swap injectors.
     
  3. cmontel727

    cmontel727 New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    Location:
    Newton, NJ
    I have moved the plug and the coil, still misfiring on number six. Planning to swap injectors this weekend!
     
  4. 1BADKJ

    1BADKJ Full Access Member

    Messages:
    502
    Likes Received:
    1
    Joined:
    Feb 18, 2012
    Location:
    Barnegat NJ
    Let us know
     
  5. cmontel727

    cmontel727 New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    Location:
    Newton, NJ
    Well I have some information to add....Went to move the jeep into the garage to work on swapping the injectors and it started missing again with large amounts of white smoke coming out the tailpipe. Smoke slowed down once the engine stopped missing. Had to turn it off and restart it twice to make the missing stop. This so weird, never had symptoms like this.

    Checked the antifreeze, it was low had to add about 2 quarts. I also put a vacuum gauge on it; steady vacuum of about 18psi. Plan on a compression check tomorrow.

    So I'm thinking head gasket or cracked cylinder head. I will up date everyone tomorrow after the compression check and injector swap.
     
  6. Porkchop

    Porkchop Full Access Member

    Messages:
    1,288
    Likes Received:
    0
    Joined:
    Jan 24, 2010
    Location:
    Troy Mi
    Ouch head gasket.
     
  7. cmontel727

    cmontel727 New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    Location:
    Newton, NJ
    I agree!!!

    Hear is the latest update: Did a compression test...below are the results

    1: 178
    2: 181
    3: 176
    4: 184
    5: 182
    6: 190

    I did find moisture in the #6 cylinder and the plug was glazed in white. The other plugs were normal. I did swap over the injector and cleared the codes. I let it sit for about 6 hours and on re start I'm still getting a misfire on 6. I rev it up and a lot of white smoke comes out. Then I shut it off and re start, no more smoke or misfire.

    So I think the final verdict is a crack in the cylinder head since the compression is good. I suppose a leak down test would confirm my thoughts on this being the problem.

    It's really frustrating to have this problem. I have owned since it was new and it has never overheated or run hot.

    Oh well now I have figure what my next step is gong to be. Thanks for everyone's help with this problem. I will keep everyone updated if I decide to open up the engine and fix it.
     
  8. SabaII

    SabaII Full Access Member

    Messages:
    197
    Likes Received:
    0
    Joined:
    Oct 8, 2010
    Location:
    Rochester, MN
    I have the same problem only cyl #4. Came to the same sort of conclusion only I couldn't watch my coolant usage as I had a leaky radiator but I just replaced that so I will keep an eye on it now. I am kind of over fighting it though. Until it starts happening on a regular basis I am not worrying about it. My miss is extremely random though. I can never get it to do it when I want to and when I really don't want it to miss it will.
     
  9. NJallDAY

    NJallDAY Full Access Member

    Messages:
    717
    Likes Received:
    0
    Joined:
    Sep 11, 2012
    Location:
    New Jersey
    Doesnt the 3.7 have a problem with rockers dropping off? And it presents it self as a miss fire before it does?
     
  10. SabaII

    SabaII Full Access Member

    Messages:
    197
    Likes Received:
    0
    Joined:
    Oct 8, 2010
    Location:
    Rochester, MN
    Not sure. I know they have head gasket issues but I bet someone can chime in on whether or not thats true.
     
  11. cmontel727

    cmontel727 New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    Location:
    Newton, NJ
    That has happened to others....certainly that what I was hoping was wrong with mine! Much easier fix!