My SAS is Pretty much Complete......

Red_KJ_666

Full Access Member
Joined
Apr 3, 2010
Messages
124
Reaction score
0
Location
Riverview NB Canada
You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images
 

Red_KJ_666

Full Access Member
Joined
Apr 3, 2010
Messages
124
Reaction score
0
Location
Riverview NB Canada
So now I know The Grabbers aren't great in light snow or icy conditions at all, they do seem to do pretty good aired way down tho. They are however not as bad as I thought they would be we have had it out in 2 snow storms on the road and it handles a lot better in the snow (well in every condition) than it did on my old 33" X-terrains (The worst Tire I Have ever owned). I still haven't taken the time to figure out the speedo, but we have now put enough Miles on it to get past the gear break in period. We have been just running the GPS for a speedo/Odometer doing the math of that we are getting around 23mpg (With the IAT sensor light still on I have to change that soon). It's heading back to the shop this afternoon and will be there all next week to get the rest of the little crap finished up.Shimmy Shock,Bumpers, Battery hold down,Winch mounted, and a few other things I can't think of right now.
You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images

You must be registered for see images

and then a Broken U-Joint in the Rubi 44 Axle ended our day
You must be registered for see images
 
Top