Hi, All. We are new Jeep Liberty owners. My son and I recently bought a 2011 base KK, with 78,000 mi

Discussion in 'Just registered? Post here to introduce yourself!' started by Jake's Jeep, Oct 26, 2019.

  1. Jake's Jeep

    Jake's Jeep New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Oct 26, 2019
    We already need HELP!! 2011 KK Base.M son has been driving back and forth from college, 80 miles each way, on weekends since Sept. Yesterday after a fair amount of stop and go traffic the Jeep started shaking. Made it home at low speed. Found the front left and right rear brakes were locked up. Spoke to several mechanics, one said maybe ABS pump. Any help is greatly appreciated. First time posting, hope I did it right. Thank you.
     
  2. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Welcome! When was the last time the brakes were replaced or serviced? I'd check the simple stuff first. Maybe the slide pins just froze up when they heated up with the stop and go traffic. might just need some lube. Maybe opening the bleeder will free them up if it's a fluid issue. Try a brake bleed too. Probably a good idea if you don't know the service history. Always a good idea to replace all hardware (slidepins too) when doing a brake job.
     
  3. Jake's Jeep

    Jake's Jeep New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Oct 26, 2019
    The brakes, rotors, calipers and pads, we're all replaced by dealership before we bought it. We called them for service records, no luck.
     
  4. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,477
    Likes Received:
    77
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Hmmm. Makes you wonder. I'd say have a look at what they did or take it somewhere else if you aren't comfortable doing that stuff yourself. I'm not very fluent in KKs but I don't recall hearing about ABS units/pumps failing. Seems like they didn't lube the pins right or used old dirty ones. Unless they used some cheap aftermarket calipers that failed?

    I had an intermittently wonky ABS pump in my 02 but never caused those symptoms and I had an ABS light lit on the dash.