Heater problem

rigid

Member
Joined
Sep 18, 2016
Messages
99
Reaction score
4
Location
united states
I have an 02 That I have replaced the heater core and blend door within the last 2 years. The blower motor was not working and found the problem to be the connector to the motor. The blower motor resistor was also replaced to get all four speeds to work. All of those items seem to be functioning as they should. Fast forward to now. Heat is good at the low speed sitting in the driveway. . Three and four on the dial the air is barley warm. At speed going down the highway it gets a little better but as soon as you slow down or come to a stop sign it gets cool again.

We have 2 Libertys so I am not positive that this one has a Chrysler thermostat. The radiator is approximately 4 years old. Any ideas on what the next step would be to check?

Thank you
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,708
Reaction score
1,294
Location
B.C. Canada
It could be a stuck open thermostat. Pressure test the system, (need adapter) and see if it holds pressure for 10 minutes.
If it's not holding pressure, air could be entering the system.
Have you ever changed the water pump?
 

rigid

Member
Joined
Sep 18, 2016
Messages
99
Reaction score
4
Location
united states
It could be a stuck open thermostat. Pressure test the system, (need adapter) and see if it holds pressure for 10 minutes.
If it's not holding pressure, air could be entering the system.
Have you ever changed the water pump?
No i have not changed it. I will have to get the pressure tester from autozone. Thank you
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,708
Reaction score
1,294
Location
B.C. Canada
BTW if it was a a stuck open thermostat, it would set an engine light on /code, for too long to warm up.
IDK how many miles are on your Jeep, but if the wrong coolants were ever added/used, it can damage the water pump plastic impeller, replace water pump & (flush time)
Mopar Hoat coolant or Zerex-G05 at Walmart is to be used only in our Jeeps.
 

Latest posts

Members online

Top