Heat only hot when all the way up.

frankjc

Member
Joined
Feb 15, 2020
Messages
32
Reaction score
8
Hi. 2012 Liberty Jet Limited.
New thing going on with the heat. When i turn the temp ALL the way up, its nice and hot. If i set it any lower, like 75 for example, we get cold air. If i watch the actuator, it seems like it only goes all the way cold, or all the way hot, no in between. Coolant level is right where it should be.
A little history on the car.
New heater core (was leaking) and distribution box (broken gears): about 1.5 years ago. New Mopar water pump, about 1.5 months ago.
Was working fine until about a week ago, as I was told.
 

John P.

Full Access Member
Joined
Aug 13, 2019
Messages
145
Reaction score
53
Location
Council Bluffs, IA
Are your controls the dial type? I would start by checking the connectors to be sure they are securely locked in. If they are, I would replace the HVAC control unit. Relatively cheap to source used. I wouldn't think the actuator would be the problem since it has full range and you've replaced the box.
 

KKinTexas

New Member
Joined
Jan 11, 2018
Messages
29
Reaction score
10
Location
US
Hi. 2012 Liberty Jet Limited.
New thing going on with the heat. When i turn the temp ALL the way up, its nice and hot. If i set it any lower, like 75 for example, we get cold air. If i watch the actuator, it seems like it only goes all the way cold, or all the way hot, no in between. Coolant level is right where it should be.
A little history on the car.
New heater core (was leaking) and distribution box (broken gears): about 1.5 years ago. New Mopar water pump, about 1.5 months ago.
Was working fine until about a week ago, as I was told.
I have a control unit I can sell you if you want. DM me.
 

Latest posts

Members online

Top