FSM for Valve Cover Gasket Replacement

Discussion in 'How To' started by AZBuman, Jun 4, 2018.

  1. AZBuman

    AZBuman New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 8, 2015
    Location:
    Maryland
    Good afternoon all. Its been a while since I posted but I got a question for the group. Does anyone have a good line on a factory service manual in order to do the valve cover replacement? I searched this morning and I found a bunch of broken links from a few years back.

    I've seen the job done on youtube and it seems pretty straight forward, but I like to have the FSM on hand just for reference.

    If there isn't a good link or source, is the Haynes manual just fine? I can probably pick on up on Amazon or something.

    The repair will be on my mom's 2004 Liberty 181,xxx miles on it. Her daily driver. We just drove it up from AZ to CO and I had it parked in the garage for a couple days. When I moved it, I saw a little bit of oil on the ground, so I got underneath to see if I could see where the leak was coming from. I pin pointed it to the rear passenger side of the valve cover, dripping down to near the o2 sensor onto the exhaust pipe.

    I went and did some searching on-line and found this to be a common problem with the 3.7. (My experience is more with Toyota 2UZ-FE engines) I have all the tools l need to the job. Thanks for any help in advance.
     
  2. Gyro

    Gyro Full Access Member

    Messages:
    279
    Likes Received:
    12
    Joined:
    Sep 12, 2012
    Location:
    Nova Scotia
  3. AZBuman

    AZBuman New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 8, 2015
    Location:
    Maryland
    Thank you much! Very appreciated.
     
  4. 04Liberty

    04Liberty Full Access Member

    Messages:
    1,179
    Likes Received:
    7
    Joined:
    Sep 14, 2006
    Location:
    MD
  5. Jbergun

    Jbergun Full Access Member

    Messages:
    1,009
    Likes Received:
    0
    Joined:
    Jun 4, 2015
    Location:
    Chicago
    Did you get it done how was it
     
  6. AZBuman

    AZBuman New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 8, 2015
    Location:
    Maryland
    Not so much

    Well I tore into the passenger side this AM and was unable to clear away all that I had to in order to get to the valve cover. I couldn’t move the metal heater hoses (I think that is what they are) out of the way. I couldn’t figure out how to move the plastic clip near the firewall. It looks like it is covering the last stud on the valve cover too. Also all of the ignition clips broke as soon a any pressure was applied. All in all a very frustrating day and no success. I tried uploading a pic from my phone but I can’t get it small enough for the site.
     
  7. AZBuman

    AZBuman New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 8, 2015
    Location:
    Maryland
    I was able to upload some photos of the part. The close up shows where it is attached to the stud. Man I pulled on that thing and couldn't budge it. The topside photo shows the black plastic around the heater hoses. I wasn't able to open that clip with a flat head screw driver. I think if I can get that off everything else will fall into place.
     

    Attached Files: