Driver’s side running lights not working on 07 KJ keep blowing fuse where to find the short?

Shaneomac

New Member
Joined
Jan 28, 2022
Messages
1
Reaction score
0
I have 07 KJ just purchased and the drivers side running lights are not working front or back replaced fuse and blows again. Anyone have a fix to find the short
 

jeepman1946

New Member
Joined
Nov 23, 2021
Messages
3
Reaction score
1
IF you have a trailer tow set up, check that first. If there is corrosion or debri there it could be causing a short. If that doesn't fix it, pull the bulbs out and examine them. I had one go bad and short out the fuse.

Hope that does it. If not, you will be digging into chassis wiring.
 

mike808

New Member
Joined
Jul 19, 2015
Messages
10
Reaction score
16
Location
San Diego
Did you ever resolve this issue? I have the same issue on my 03 renegade. No position lights on the driver's side and no turn signals. But all other lights work. I've changed all the bulbs and even the actual taillight assemblies along with the rear upper brake light. No trailer hitch installed (awaiting dealer parts so they can install, never had one).
 

Jeremy-WI

Full Access Member
Joined
May 20, 2017
Messages
281
Reaction score
86
Location
Home
Check the wires going to the license plate light, it might be shorted
 

sota

Full Access Member
Joined
Apr 6, 2011
Messages
1,951
Reaction score
536
Location
NJ
I recently had it where my trailer adapter took a carp, and it was blowing the fuse for the driver's side.
 
  • Like
Reactions: JRB
Top