Cylinder 2 misfire only at start up

Aceofspades

Full Access Member
Joined
Jan 24, 2017
Messages
780
Reaction score
101
Location
Buffalo
Curious if anyone else has experienced a similar scenario. Jeep sits for any period of time , the first start up usually a rough idle , cylinder 2 misfire. However. After you shut it off and restart the issue goes away. Sometimes it takes a couple tries.
After this it drives fine and can start stop no problem. After a while I made the time to tear into engine as it needed valve cover gaskets replacements on both sides.
The cylinder 2 plug came out with the ground strap partially worn down.

Key points.
Issue occurs when Jeep sits.
Cylinder 2
After restarting it runs perfect. Continues to run perfect until it sits for a while.


Changes made
New plugs. Coils. Injector (theory was it was leaking over time fouling the spark)


Conclusion.

It’s been one week. No issues. Thought it was fixed. It’s now doing the same thing. Would love to hear some new ideas as I have my hands full with other vehicles and the Jeep just continues to throw issues at me.
Thanks in advance
 

DadOSix

Full Access Member
Joined
May 20, 2020
Messages
516
Reaction score
258
Location
Cumberland, MD.
My 06 was carrying on with rough idle, random misfire.

Eventually showed up as a marginal injector. Made a trip to the parts yard and found a donor that i was able to score 3 injectors from.

Seemed to do the trick.

Took the 'bad' one and bench tested with carb cleaner and a battery. Eventually it sprayed a decent pattern, but i tossed it anyway.
 

Ksat

Full Access Member
Joined
Nov 11, 2018
Messages
157
Reaction score
67
Location
ny
How did the #2 spark lug look in comparison to others in the engine? If #2 looked vastly different (and all plugs have the same mileage). I would suspect you have an issue in that cylinder like a bad head gasket or detonation.
 

Aceofspades

Full Access Member
Joined
Jan 24, 2017
Messages
780
Reaction score
101
Location
Buffalo
My 06 was carrying on with rough idle, random misfire.

Eventually showed up as a marginal injector. Made a trip to the parts yard and found a donor that i was able to score 3 injectors from.

Seemed to do the trick.

Took the 'bad' one and bench tested with carb cleaner and a battery. Eventually it sprayed a decent pattern, but i tossed it anyway.
Yea I’ve replaced all that to clear any possibility of bad plugs injectors or coils.
 

Aceofspades

Full Access Member
Joined
Jan 24, 2017
Messages
780
Reaction score
101
Location
Buffalo
How did the #2 spark lug look in comparison to others in the engine? If #2 looked vastly different (and all plugs have the same mileage). I would suspect you have an issue in that cylinder like a bad head gasket or detonation.
Yes - since doing this about a week or so ago, I want to pull the plug on #2 and see what it looks like. I’ve put about 250-300 miles on it so far
 

Latest posts

Members online

Top