Bucking at 40mph

Discussion in 'KJ General Discussion' started by dentwizz, Dec 21, 2011.

  1. dentwizz

    dentwizz Full Access Member

    Messages:
    86
    Likes Received:
    0
    Joined:
    Jul 7, 2009
    Location:
    Strasburg, PA
    Recently I have noticed the lib has a "buck" or hesitation when at 40mph going up a hill I get behind someone. It doesn't do it if I "OD OFF" button, but it's like its confused on the gearing. Going up the hill faster or slower doesn't make an issue but 40 does. Is this fairly common? As stated, I did not notice this until recently. I hope it is nothing major about to happen since I can barely afford to drive it as is...
     
  2. tommudd

    tommudd Moderator Staff Member Moderator

    Messages:
    17,858
    Likes Received:
    453
    Joined:
    Jul 14, 2005
    Location:
    Southeastern Ohio
    How long have you been running that K&N ?
     
  3. dentwizz

    dentwizz Full Access Member

    Messages:
    86
    Likes Received:
    0
    Joined:
    Jul 7, 2009
    Location:
    Strasburg, PA
    50k and cleaned/checked on interval. Stock intake with KN element more specifically...
     
  4. tommudd

    tommudd Moderator Staff Member Moderator

    Messages:
    17,858
    Likes Received:
    453
    Joined:
    Jul 14, 2005
    Location:
    Southeastern Ohio
    But have you cleaned the intake etc, K&Ns are known to suck in lots of dirt and crap, could be a start
    When was the last tuneup done and with what plugs ?
    Have you changed where you buy your gas?
     
  5. dentwizz

    dentwizz Full Access Member

    Messages:
    86
    Likes Received:
    0
    Joined:
    Jul 7, 2009
    Location:
    Strasburg, PA
    Fuel sources have been consistent, power band has been where it usually was. I just had the plugs out for inspection and they were all on spec(even after 40k). Trans fluid was changed in feb.
     
  6. Porkchop

    Porkchop Full Access Member

    Messages:
    1,288
    Likes Received:
    0
    Joined:
    Jan 24, 2010
    Location:
    Troy Mi
    My 07 did this 2yrs ago everything checked out on the scan so I had to take it to 3 dealers before I found a dealer who had it for 1.5 hrs to do a trans up date and fluid check.
    As soon as I left the dealership I knew it was fixed.
    Next day I go back to the dealer to ask what up date they did and as they would close there doors for good today they couldnt tell me.
    When I took it to the other dealers they said thats just how KJs are I hate that bs they give never told them I was a tech and knew it was the trans doing it.
    So makes me wonder if the up date was done on your 05?
    Makes a big dif when going with bigger tire size.
     
  7. dentwizz

    dentwizz Full Access Member

    Messages:
    86
    Likes Received:
    0
    Joined:
    Jul 7, 2009
    Location:
    Strasburg, PA
    Good to know. I was thinking it might be software. The tire size is stock at least. Maybe I'll make a visit to the dealer then. Did they charge any to do it?
     
  8. Porkchop

    Porkchop Full Access Member

    Messages:
    1,288
    Likes Received:
    0
    Joined:
    Jan 24, 2010
    Location:
    Troy Mi
    No and gave me no paperwork just said dont worry abought it. I thought Oh no and drove it home only to find that it realy was fixed. Thats why I went back the next day and suprise they would lock the doors today.
    Funny thing
    1. Is hard for me to let anyone work on my rides.
    2. When I snooped in the shop to see what thay were doing.
    The tech,she had it on the hoist runing. She had so much equipment hooked to my jeep I thought Oh no my KJ looks as if it is in the ICU. Now when she drove it out to me shes says nick KJ I checked all fluids for you sur and when I got home and checked she sure did.
    Sorry for the tap talk!
     
    Last edited: Dec 24, 2011