Brake lights and high mount brake light not working

Discussion in 'KJ General Discussion' started by cesarsoto, Jan 29, 2016.

  1. cesarsoto

    cesarsoto New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jan 29, 2016
    Location:
    mesa az
    have an 04 jeep liberty, both left and right brake lights are not working and neither is the high mount brake light, have changed all the bulbs and verified they are the right size, have changed the brake light switch and still no power to the brake lights, any idea what fuse to check or what to check next?
     
  2. Billwill

    Billwill Full Access Member

    Messages:
    1,319
    Likes Received:
    64
    Joined:
    Nov 26, 2009
    Location:
    White River, South Africa
    Try fuse 12 (15 A) on the inside fuse panel.

    Will not be a grounding issue as the lower brake light use a different ground to the high mount brake light.

    A bad Trailer Tow installation can also cause problems.:shrug:
     
  3. ArtO

    ArtO Full Access Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Jun 18, 2015
    Location:
    Weedsport
    I've never checked my KJ but on my '08 HHR the brake lights would only work if the car was running. Chevy tech said this was normal. Just throwing this out there.
     
  4. uss2defiant

    uss2defiant Full Access Member

    Messages:
    3,299
    Likes Received:
    15
    Joined:
    Jun 25, 2014
    Location:
    Tucson, Arizona
    KJ brake light will come one regardless of whether the jeep is running or not.
     
  5. teeje

    teeje Full Access Member

    Messages:
    735
    Likes Received:
    0
    Joined:
    May 5, 2014
    Location:
    Toledo
    Take the brake light switch out and test for continuity. My cruise control wouldn't work because the resistance was too high


    2002 Jeep Liberty 3.7L with brand new engine ;)
    Sent from my iPhone using Tapatalk
     
  6. Cpt Marvel

    Cpt Marvel Full Access Member

    Messages:
    153
    Likes Received:
    0
    Joined:
    Sep 1, 2015
    Location:
    Clarksville, Tn
    If your dash lights aren't working either, more than likely the fuse.