Bad oil pressure sensor?

Discussion in 'KJ General Discussion' started by HoosierJeeper, Aug 18, 2019.

  1. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,621
    Likes Received:
    35
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    Sometimes when I start the KJ in the morning the oil pressure light stays on after the other lights go out. I can shut it off and restart immediately and it goes off. No weird noises at all. No rattles or anything - did an oil/filter change to rule a bad ADBV out.

    The sensor is covered in oil, it's been leaking from there for a long time. Never see the light any other time.
     
  2. LibertyTC

    LibertyTC Well-Known Member Staff Member Moderator

    Messages:
    6,314
    Likes Received:
    123
    Joined:
    Oct 24, 2008
    Location:
    B.C. Canada
    Interesting that the pressure light stays on. In a a way this is good as it's hinting something's up and to look for a leak.
    Definitely with a leak at sensor, replace it with a Mopar one.
    I am surprised you did not replace it sooner!
     
  3. ltd02

    ltd02 Comfortably numb KJ Supporting Member

    Messages:
    2,445
    Likes Received:
    68
    Joined:
    Aug 15, 2014
    Location:
    North Central Maryland
    Mine did that in my 05 when it failed. Replaced it and all good. Don't forget to get the one for a switch not a gauge. I made that mistake years ago with my 02...
     
  4. kejobe

    kejobe Full Access Member

    Messages:
    309
    Likes Received:
    9
    Joined:
    Sep 5, 2016
    Location:
    NE Ohio
    Mine did the same after using the cheap STP oil and filter a week later. Changed to Mobil 1 oil and Mopar filter. Still happened but only about 60% of the time. Changed the sensor and it quit staying on.