Adding OEM subwoofer option to a 2012 KK

Discussion in 'KK General Discussion' started by mushupork, Oct 8, 2019.

  1. mushupork

    mushupork New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 6, 2010
    Location:
    WI
    I have a Liberty KK that did not originally have the OEM subwoofer. (I don't want to do an aftermarket sub.)

    I bought a new OEM subwoofer for a reasonable price and and also found the rear quarter body panel with the sub pocket from a scrapyard. I removed the body panel to install assuming from a previous USB port adapter install that the connector for the sub woofer to plug into would be on the uConnect module behind the rear quarter panel. I was wrong.

    Does anyone with the factory subwoofer know if there is a separate amp involved and how it connects? Maybe a model number I can google with etc. ?

    Thanks for any help. I have searched and it doesn't look like people have done what I do - or at least have not written about it.
     
  2. lfhoward

    lfhoward Full Access Member

    Messages:
    83
    Likes Received:
    23
    Joined:
    Dec 9, 2012
    Location:
    Philadelphia, PA
    Any chance you can go back to the scrap yard and take a look at the donor Jeep? I bet you’d be able to find the sub wiring and trace it back to an amplifier, which I suspect is under the rear seat. You could also snag those components if someone hasn’t beaten you to it.

    I don’t have the subwoofer option, otherwise I’d go check for you on mine.
     
  3. John P.

    John P. Member

    Messages:
    32
    Likes Received:
    6
    Joined:
    Aug 13, 2019
    Location:
    Council Bluffs, IA
    Mine has it, I’ll try and check tomorrow when I get home
     
  4. mushupork

    mushupork New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 6, 2010
    Location:
    WI
    lfhoward : thanks but I didn't see the donor vehicle

    John P. : thanks. The sub woofer itself has a little grey pigtail connector which is pretty short so the amp must be very close to the Bluetooth module when installed.

    I took some pics of the uConnect module (68104905AC) area/pocket when I had the body panel down. The uConnect had an open connector area that I thought this sub woofer pigtail I mentioned above would plug into but I was wrong of course.

    There were a couple connectors in the electrical wiring bundle itself behind that body panel but they were located above the wheel well far away from the uConnect area pocket where the sub will live. Also nothing that looked obviously like it would plug into an amp.
     

    Attached Files:

  5. John P.

    John P. Member

    Messages:
    32
    Likes Received:
    6
    Joined:
    Aug 13, 2019
    Location:
    Council Bluffs, IA
    I haven’t forgot about this. I didn’t make it home as planned so I’ll look next week when hopefully I’ll be home.
     
  6. mushupork

    mushupork New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 6, 2010
    Location:
    WI
    Thanks John P.