545RFE and cold weather.

Discussion in 'CRD KJ's Section' started by LibertyOrDeath, Nov 22, 2010.

  1. LibertyOrDeath

    LibertyOrDeath Full Access Member

    Messages:
    1,677
    Likes Received:
    0
    Joined:
    Oct 4, 2007
    Location:
    Grays Harbor County, SW Washington
    I put this in the CRD section because the transmission is the same.

    I just got off work, I was parked outside in where it was about 31. I let the Jeep warm up for a one or two minutes and when I went to leave my transmission delayed shifting into reverse. A smaller delay when shifting to drive. I drove about a mile down the road and my engine died as I came to a complete stop. No warning lights came on it was just like I turned off the ignition. It did it a few more times but didn't shut off if I shifted to N right before I stopped. As I warmed up it stopped doing it. Is this a sign of something going wrong with my Jeep or somewhat normal for such cold weather.
     
  2. bugnout

    bugnout Full Access Member

    Messages:
    166
    Likes Received:
    0
    Joined:
    Jul 13, 2006
    Location:
    Illinois
    Might be time to service the filters.

    Never had mine stall on me, but I have had to let the pressure build before she would engage when really cold out. The tranny pump doesn't run in park, so try putting it in Nuetral for about 15-30 seconds when cold.
     
  3. JoBo

    JoBo New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Nov 27, 2006
    Location:
    Columbus, Ohio
    When CRD's stall like that the torque converter is not unlocking and that's not a good sign.

    New filters and fluid might be the answer if the drain back valve in the spin on filter is failing and allowing the tranmission fluid to drain out of the torque converter.
    In the mean time get it to normal temperature and check the fluid level.

    I believe the tranny pump runs whenever the engine is running.
     
  4. flman

    flman Full Access Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Aug 28, 2009
    Location:
    jyjhbkbu
  5. LibertyOrDeath

    LibertyOrDeath Full Access Member

    Messages:
    1,677
    Likes Received:
    0
    Joined:
    Oct 4, 2007
    Location:
    Grays Harbor County, SW Washington
    So just an update. This phenomenon went away when the weather warmed up. Until about a week ago, it started shifting harshly and acting real funny. However, it wouldn't stall when I stopped. By the time I could get it into the shop it started to slip and I wasn't able to use any gear higher than 2nd. If It shifted into 3rd I would have to stop and use my shifter to keep in from shifting into 3rd because all it would do was slip. Diagnosis from the shop: Tranny is fubar. Thank god for buying a warranty.
     
  6. Marlon_JB2

    Marlon_JB2 Kombat Edition Jeep

    Messages:
    14,991
    Likes Received:
    3
    Joined:
    Nov 20, 2004
    Location:
    Clinton Township, MI
    My CRD with the 545RFE did this after the F37 recall. The problem was low transmission fluid. The transmission never ran right after that and that is why I had no choice to dump it. The shop kept saying everything was fine. Grr.
     
    Last edited: Jan 29, 2011