2007 Liberty front vibration

Discussion in 'KJ General Discussion' started by jetmech84, Nov 5, 2017.

  1. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    2007 Liberty front vibration: cv axle or bad engine ?

    I have been looking for the cause of a front vibe using a ton of great info on this forum. Started out by noticing the boot on the aft CV joint on the front propeller shaft was pretty much gone and the joint was sloppy. Removed the shaft and replaced the CV joint. The front joint was tight and moved freely so I left it alone. Put the shaft back in and it was better but still noticeable above 45 mph. Wheel bearings and ball joints seem to be in good shape but if I put my hand on the passenger side cv axle to intermediate shaft joint I can push the CV axle up about 10 degrees very easily. From everything I have read here this is not good. So this past week I took the Jeep to a local shop who said he works on a lot of Jeeps to get the cv axle and intermediate shaft replaced. He called me the next morning to tell me the drive line was fine and he is certain the vibration is actually a pulse in the exhaust system and I am going to need a new engine soon. It only has 129,000 miles on it and I would be surprised if the engine was no good any more. Needless to say I paid him a small diagnostic fee and ran away as fast as I could. I love this Jeep but can't afford a new or reman engine right now. Any words of wisdom from this group would be greatly appreciated.

    Thanks everyone.
     
    Last edited: Nov 5, 2017
  2. Myke

    Myke Full Access Member

    Messages:
    562
    Likes Received:
    4
    Joined:
    Nov 13, 2016
    Location:
    USA
    Where are you located? Maybe one of us is close enough to check it out in person or suggest a quality mechanic.

    Is it lifted? Any other mods?

    The cv should only move in towards the engine and out towards the wheel (left/right) not up and down I believe.
     
  3. Myke

    Myke Full Access Member

    Messages:
    562
    Likes Received:
    4
    Joined:
    Nov 13, 2016
    Location:
    USA
    Did you check your ball joints? Rear shaft u joints?
     
  4. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    I'm in Michigan, near Kalamazoo. Rear u joints seem fine. Just had the diff fluid and t-case fluid replaced. No leaks of any kind underneath.
     
  5. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    And yes, it is lifted. Sorry, forgot to answer that one.
     
  6. Myke

    Myke Full Access Member

    Messages:
    562
    Likes Received:
    4
    Joined:
    Nov 13, 2016
    Location:
    USA
    How big of a lift. You're rear pinion angle can cause vibs around that speed.
     
  7. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    It's a Daystar (I think) 2.5 lift kit. I did not install it - it was already lifted when I bought it 2 years ago. Ran fine with no vibes back then but about late May I stated noticing the vibes.
     
  8. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,697
    Likes Received:
    72
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    I'm guessing intermediate shaft. Does it kind of sound/feel like an out of balance tire? That's how mine felt.

    U joints can cause a vibration too, but they also usually make noises too. Any chirping sounds at low speeds?
     
  9. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    Yes, it does kind of sound like an out of balance tire but I know they are good. Had them checked before I joined this group. No chirping or squeaking type sounds. Just the "thumping" sound when I am above about 45 mph. I put it on jack stands last weekend and took the front right tire off so I could watch the CV axle. When I rotate the hub the CV joint next to the intermediate shaft runs true for most of the revolution then kind of twists and jumps before running true again. Does it at very nearly the same spot every time. I really think I am going to have the intermediate shaft and passenger side CV axle replaced. Anyone else ever been told that a vibration can be caused by the exhaust ? This guy never did answer how that could happen. My assumption would be a valve issue ??
     
  10. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,697
    Likes Received:
    72
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    I've never heard of exhaust causing a vibration...I mean maybe if something is seriously messed up but I'm guessing the vibration would be the least of your concerns.

    Get a Napa reman passenger side CV and find an intermediate shaft on eBay, they're all the same.
     
  11. rjkj2005

    rjkj2005 Full Access Member

    Messages:
    380
    Likes Received:
    0
    Joined:
    Feb 25, 2016
    Location:
    US
    This nylon bearing wears out in the passenger side axle tube. You can see how the bottom is worn. This allows the CV and inner axle to move up and down causing a vibration. There is a metal needle bearing available for a replacement.[​IMG]

    Sent from my XT1585 using Tapatalk
     
  12. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    Exactly HoosierJeeper. That's what I was thinking too. Going with the NAPA reman and found the shaft on eBay for $98.00. Seriously appreciate your input and help.
     
  13. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    Thanks rjkj2005 ! Excellent picture and I suspect that's my issue.
     
  14. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,697
    Likes Received:
    72
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    No prob!

    I've heard it's kind of a b1tch to get to, that bearing. At 129k, you might just need the intermediate shaft and CV. That's all I've replaced on mine. Probably jinxed it now though. :gr_grin: Typically, the bearing makes a click noise. If you're replacing it yourself, I'd consider just doing the intermediate shaft and CV. If you're taking it in, I'd have them do the bearing and seal too.
     
  15. jetmech84

    jetmech84 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 12, 2017
    Location:
    49053
    I will be taking somewhere as soon as I find a mechanic with his brain in his head and not his buns. I'll have him look for the metal needle bearing that was mentioned in an earlier reply. I'll continue the thread as soon as I get the work done so I can share the result with the group.
     
  16. HoosierJeeper

    HoosierJeeper Gold Supporter/Admin Staff Member Administrator

    Messages:
    20,697
    Likes Received:
    72
    Joined:
    Jan 20, 2009
    Location:
    Western WI
    Find a place that'll let you bring stuff in. You might have to spec an 02 when you order the bearing, I think after 02 they got plastic but they might have even replaced that part # with plastic.
     
  17. kejobe

    kejobe Full Access Member

    Messages:
    349
    Likes Received:
    31
    Joined:
    Sep 5, 2016
    Location:
    NE Ohio
  18. rjkj2005

    rjkj2005 Full Access Member

    Messages:
    380
    Likes Received:
    0
    Joined:
    Feb 25, 2016
    Location:
    US
  19. kejobe

    kejobe Full Access Member

    Messages:
    349
    Likes Received:
    31
    Joined:
    Sep 5, 2016
    Location:
    NE Ohio
    I was just looking for if/when I need to do the cv's. Not needed right now. :gr_grin:
     
  20. smittyfromPA

    smittyfromPA Full Access Member

    Messages:
    200
    Likes Received:
    1
    Joined:
    Nov 7, 2013
    Location:
    PA
    I had both CV axles and Intermediate replaced a few months ago and I still get a vibration noticeable after 55MPH. Its a rhythmic whoop-whoop or like a thuuuump thuuuump sound. Had tires balanced and rotated to rule that out. Rear u-joint and front driveshaft both replaced 26K miles ago, new upper and lower ball joints 11K miles ago. I stopped letting it drive me crazy (because it was driving me nuts) and just turn up the radio on the highway.
     
    capecodbob likes this.