2005 KJ Cherokke shift delay problem at first start

can

New Member
Joined
Nov 16, 2021
Messages
9
Reaction score
0
Dear All,

I have shift delay problem at the first start every morning..
could you please share with your experiences about the possible reasons to fix this problem??
thanks,
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,708
Reaction score
1,294
Location
B.C. Canada
Could be initially a tad low on ATF+4 fluid. Add some. I let jeep warm for 3 minutes, in neutral.
Keep in mind that it takes some driving to warm the fluid up.
On level ground after driving for 20 minutes, apply hand brake & check fluid level in neutral, it should be just above the full line.
 

can

New Member
Joined
Nov 16, 2021
Messages
9
Reaction score
0
thanks for your comment.. I have checked the fluid level it is ok, no problem.. I have replaced the transmission fluid, samp filter and also cooler return filter 1 monts ago.. may be it is related with this operation ( ı suspect sump filter o ring or cooler return filter montage problem ) it seems the oil drains to the pan if the vehicle stops 10-12 hours...
 

JibeHo22

New Member
Joined
Dec 7, 2021
Messages
18
Reaction score
8
Please elaborate on "cooler return filter montage problem". Never heard of that one.
 

budget76

New Member
Joined
Sep 1, 2021
Messages
11
Reaction score
3
Are we leaking fluid? Look AGAIN to rule this out. Check level AGAIN, it never hurts. If you changed the tran pan (you did not say you did), the newer pan may be deeper and require more MM on tran dip stick to be at same level. Just my 2 cents.
 
Top