2002 Liberty Engine Dying

2002_KJ

Member
Joined
Jan 18, 2022
Messages
52
Reaction score
18
Location
Italy
Got my 2002 Liberty (3.7L V6 gas automatic) back from the mechanic here in Italy. He replaced some parts like accessory belt, battery, fluids, etc. and said the car was running fine. Not sure exactly what he did because he did this work as a favor to my uncle so it's not like he was going out of his way to check closely or find stuff to fix to get paid. When I got the car back the radio code had to be re-inserted and the air bag light was on (mechanic left a note saying the light would go off on its own after driving for a bit and that it was on due to battery replacement; don't know whether this is true or not). Never got a chance to talk to the guy...this is how stuff works in Italy...sigh.

Took the car to a body shop to fix a couple dents so I didn't drive it around all that much after the mechanic but it seemed to be running just fine. The tank was near empty but certainly no gas light. When I picked up the car several days later I didn't notice any gas light being on but when I got home and while maneuvering to park the engine died out. Turned it back on, finished parking and engine died again except this time the gas light came on. Basically the RPMs would slowly fall really low and "gently" die but all the dash lights stayed on. Not knowing what to do I tried turning the engine on again not being sure if it was a gas issue since the gas light had only just turned on, but it kept dying. Body shop guy came over to help, we drove to my nearest gas station (almost as if as long as we were moving forward the engine wasn't dying like while being still) filled up to about quarter tank full. After putting some gas in the tank we drove a short distance to test, came to a stop and it died again. He started up again, we kept driving except this time he pushed the accelerator hard almost to the redline (which I thought was a bad idea on a 20 year old car but I didn't know better); not sure why he did this. After this move we went back to the parking spot and the engine oil light came on which I guess was from pushing the engine so hard? Turned off the car for a while, oil light went off, I parked and turned off the car. I waited a bit, turned on the engine again and let it idle in park, this time it idled around 1,000 RPM and stayed there for 15 minutes without dying, no oil light, then turned off the car. I started the car up again, let it idle in park for 10-15 mins, no oil light, engine didn't die. This morning I went back, turned on the engine, let it idle again parked and it was idling slightly above 1,000 rpm in park and didn't die.

What the heck happened? I was perplexed because the gas light wasn't on when I picked it up from the body shop, at least i didn't notice but it couldn't have been on. It only came on after it died the first time while I was parking, but that seems odd because shouldn't there be reserve gas? I'm going to take the car back to the mechanic because I'm worried about the body shop guy pushing the engine almost to redline and of course because of the engine dying. No engine light came on while idling this morning but I thought I saw the engine light flash a couple times when I had the key inserted before turning the engine on. In any case there was no light on while the engine was running.

Any ideas about what may have happened? Why would it die like that, why would the oil light come on after pushing the motor really hard, let it idle this morning for 15 minutes and seems normal. I dunno, I'm perplexed Thanks for any help, sorry for the long post and the bad grammar, I'm tired...
 
Last edited:

tommudd

Moderator
Staff member
Moderator
Joined
Jul 14, 2005
Messages
22,235
Reaction score
3,427
Location
Southeastern Ohio
I have seen a couple that I was working on, gas light was not on sitting or running down a fairly level road, but on slight slope it would come on, so from sounds of it seems like it was low on gas
Oil Light, these have an issue where oil light comes on at time due to a bad oil sending unit, yours could be weak and by revving it up and you are a bit low on oil could cause it
How high was it revved up ? mine is up to 5 grand or so daily , was it more then that ? I would not think that would hurt it at all if motor is in good condition
 

2002_KJ

Member
Joined
Jan 18, 2022
Messages
52
Reaction score
18
Location
Italy
I have seen a couple that I was working on, gas light was not on sitting or running down a fairly level road, but on slight slope it would come on, so from sounds of it seems like it was low on gas
Oil Light, these have an issue where oil light comes on at time due to a bad oil sending unit, yours could be weak and by revving it up and you are a bit low on oil could cause it
How high was it revved up ? mine is up to 5 grand or so daily , was it more then that ? I would not think that would hurt it at all if motor is in good condition
So come to think of it, I was parking in a place where there was a *slight* incline...

I'm not sure how high he revved it...I was silently freaking out when he did it. I'm trying to baby this car since it's old and I want it to last. I glanced over the RPM gauge when he stomped on the accelerator and it was basically a hair under the "red zone" so I'm guessing around 5,000.

He said soemething about revving that high because maybe it was using remnant gas which can cause problems? I dunno man. I'm kinda paranoid about these things by nature so there's that...

Again, i just thought it was weird that the car would die like that when the light had barely been on. Anyways, I appreciate the help with this.
 

gayle.woods

New Member
Joined
Dec 18, 2021
Messages
15
Reaction score
9
Do you have access to an automotive scan tool to check for active data stream. I would suggest to clean the throttle body well. It could be several things, do a through visual inspection of the engine compartment to see if anything is unhooked or broken wires to any of the sensors. Go under the vehicle and inspect the wiring to both upstream and downstream O2 sensors for any damage.
 

2002_KJ

Member
Joined
Jan 18, 2022
Messages
52
Reaction score
18
Location
Italy
Do you have access to an automotive scan tool to check for active data stream. I would suggest to clean the throttle body well. It could be several things, do a through visual inspection of the engine compartment to see if anything is unhooked or broken wires to any of the sensors. Go under the vehicle and inspect the wiring to both upstream and downstream O2 sensors for any damage.
I don't have access to a scan tool, though I wouldn't mind investing in one (suggestions appreciated if that's not against any rule or anything).

I'll definitely check those things out. I took the car out for like a 2-3 hour drive yesterday in the mountains and it was running like nothing happened at all. Checked the engine oil and it was in the lower range of the "safe zone."

Thanks for your advice.
 

gayle.woods

New Member
Joined
Dec 18, 2021
Messages
15
Reaction score
9
Automotive scan tools come in all shapes and sizes. I have tried three different models so far. Right now I have a Topdon Phoenix Plus. Most will read generic codes and clear them. Others are bi-directional and can operate certain modules. I would recommend on that can at least read live data. Being able to see your fuel trims, watch your O2 sensors operate and other PID's is important in making a diagnosis. Some have "Freeze Frame" which can be helpful if and when the PCM sets a CEL it will show what the PID's were at the time the code was set. For the most part the more the cost the more they will do. There is plenty of information on Google on how to pick an automotive scanner. I suggest to pick one that can be returned if you find out it does not work for what your are trying to do.
 

WheelNut

Member
Joined
Feb 16, 2021
Messages
85
Reaction score
54
Location
Vancouver, BC
I believe the mechanic was giving your truck what we in America would call "The Italian tune up." Obviously, this is an authentic Italian tune up as it is actually in Italy! Running the engine at high RPM for a short period of time can help remove carbon deposits and can help keep your engine internals clean. Running up to redline shouldn't harm your engine unless there is an underlying problem with oiling, cooling, or the reciprocating parts of the engine.
 

2002_KJ

Member
Joined
Jan 18, 2022
Messages
52
Reaction score
18
Location
Italy
I believe the mechanic was giving your truck what we in America would call "The Italian tune up." Obviously, this is an authentic Italian tune up as it is actually in Italy! Running the engine at high RPM for a short period of time can help remove carbon deposits and can help keep your engine internals clean. Running up to redline shouldn't harm your engine unless there is an underlying problem with oiling, cooling, or the reciprocating parts of the engine.
Would it make sense that the oil light would come on after he did that very high-revving a couple times in a row? The oil light never comes on at all with normal driving, it's the only time I've seen it. The oil light came on maybe a few minutes after he pushed it hard the second time. We stopped the car, turned off the engine for 10 minutes, and then the light was gone and I haven't seen it since.
 

WheelNut

Member
Joined
Feb 16, 2021
Messages
85
Reaction score
54
Location
Vancouver, BC
Perhaps if the engine was quite cold and the oil was still very thick then the oil pressure may have dropped below the minimum pressure when he let off the throttle. I used to get the low oil pressure light popping up sometimes in my old E36 when it was cold out, the engine was cold, and the AC was on.

Like Gayle.Woods said- get a scan tool and chart the oil pressure while driving and see what the range is. You can buy a bluetooth OBD2 adapter and then use an app like Carly (there are probably better ones out there) to get lots of info from the vehicle's systems without having to spend much. If you plan to work on your Jeep or any other vehicle in the future having a scanner is an essential tool.
 

KKinTexas

New Member
Joined
Jan 11, 2018
Messages
29
Reaction score
10
Location
US
I believe the mechanic was giving your truck what we in America would call "The Italian tune up." Obviously, this is an authentic Italian tune up as it is actually in Italy! Running the engine at high RPM for a short period of time can help remove carbon deposits and can help keep your engine internals clean. Running up to redline shouldn't harm your engine unless there is an underlying problem with oiling, cooling, or the reciprocating parts of the engine.
Yes the 'Italian tune up'!
 

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,761
Reaction score
1,367
Location
B.C. Canada
Regarding oil light, best to check oil level on the dipstick on level ground first.
I keep oil just slightly above the full line, and check oil level every week or every fill up.
It the oil light was to continue coming on, it then could be the oil pressure sensor requiring replacement. It sounds like that has been resolved tho.
I try to never to let my fuel light come illuminate as it can cause issues with a dry fuel pump.
I also worry about fine dirt particles from bottom of tank being injected as well.

Idle rpm when cold out, can be around 1000 rpm initially parked. Once driven a tad, should idle around 650 rpm.
I think my hot idle in drive is about 600 rpm.

Is Air bag light still on? That will require a scan by a good shop scanner, and write down the codes/post em back here.
One of your local parts store may loan one to you, to then check for codes.
Tune up, have you had your spark plugs replaced ? Every 35-40k miles I replace mine. Correct spark plugs are NGK ZFR6F-11G gap .040 inch.
 

2002_KJ

Member
Joined
Jan 18, 2022
Messages
52
Reaction score
18
Location
Italy
Regarding oil light, best to check oil level on the dipstick on level ground first.
I keep oil just slightly above the full line, and check oil level every week or every fill up.
It the oil light was to continue coming on, it then could be the oil pressure sensor requiring replacement. It sounds like that has been resolved tho.
I try to never to let my fuel light come illuminate as it can cause issues with a dry fuel pump.
I also worry about fine dirt particles from bottom of tank being injected as well.

Idle rpm when cold out, can be around 1000 rpm initially parked. Once driven a tad, should idle around 650 rpm.
I think my hot idle in drive is about 600 rpm.

Is Air bag light still on? That will require a scan by a good shop scanner, and write down the codes/post em back here.
One of your local parts store may loan one to you, to then check for codes.
Tune up, have you had your spark plugs replaced ? Every 35-40k miles I replace mine. Correct spark plugs are NGK ZFR6F-11G gap .040 inch.
Yes the oil light just came on the one time, right after the body-shop guy pushed the car real hard a couple times to the red as part of the "Italian tune-up." Hasn't come on since, then again I'm a very proud "Sunday driver" so...

I worry as well about those dirt particles in the bottom of the tank, but I've gone through a few tanks of fuel since then and the engine doesn't seem to run or idle rough so I'm assuming the injectors are fine (each fill-up is about 100 euro a pop here in Italy at the moment BTW...definitely not a daily driver).

RPMs seem to follow pretty much how you described.

The air bag light is still on. Took the KJ to one dealership (not a great place) and they didn't have the right scanner to diagnose, so I'm guessing they don't have the DRBIII or an emulator for it. Took the car to the other Jeep dealership near me and the first thing they did was check for recall work...lo and behold two recalls were completed (rear reinforcement for gas tank and lower ball-joints,) but not the airbag recall from 2015 or whenever. Made an appointment for a few days from now to do the recall work under warranty; they said the ECU needs to be replaced but the recall info says the Occupant Restraint Control Module is what needs to be replaced...not sure. Anyways, they said they'll run a full diagnostic scan afterwards (I have to pay for that,) so I'm hoping they have the right scanner. If I have to pay I'm going to insist they give me every last darn detail too.

Just ordered six NGK ZFR6F-11G so I'll be replacing those myself soon along with engine oil/filter, air filter, transmission fluid, differential fluid, power steering fluid, and things like that. There's been a hissing noise coming from the rear undercarriage for quite a while, I believe near the rear differential so I'm assuming it's possibly an issue with a vacuum tube or a fuel vapor tube even though there's no check engine light...gonna need to confirm that.

Thanks for your input, much appreciated.
 
Last edited:

LibertyTC

Well-Known Member
Staff member
Moderator
Joined
Oct 24, 2008
Messages
8,761
Reaction score
1,367
Location
B.C. Canada
Very important note/ rear diff: If your rear diff is equipped with a Trac-Loc -you will need to add a 4 oz bottle of Mopar limited slip additive.
Get your free online build sheet here: https://fcacommunity.force.com/RAM/s/equipment-listing
Trac-Loc if so equipped, should be listed under differentials.
I use Lucas gear oil heavy duty DINO, not synthetics.
Hope you can find source of hissing, good luck.
 

Attachments

  • Mopar LS Additive2.jpg
    Mopar LS Additive2.jpg
    294.7 KB · Views: 2
  • Lucas Gear Lube.jpg
    Lucas Gear Lube.jpg
    436.8 KB · Views: 2

Latest posts

Members online

Top