05’ Jeep Liberty Speed Sendor

Discussion in 'Site Comments & Feedback' started by etgainey, Sep 14, 2020.

  1. etgainey

    etgainey New Member

    Messages:
    3
    Likes Received:
    1
    Joined:
    Sep 6, 2020
    Location:
    Melbourne, Fl
    My speedometer is not working. Has anyone had issues with this before that they could share? Autozone gave me a speed sensor but the one they gave seems to look like it actually goes inside the transmission. Codes also show that there is an issue with the speed sensor.
     
  2. LibertyTC

    LibertyTC Well-Known Member Staff Member Moderator

    Messages:
    7,303
    Likes Received:
    464
    Joined:
    Oct 24, 2008
    Location:
    B.C. Canada
    Known issues with the speed sensor or electrical /wiring. It is located at the rear differential.
    Inspect the wiring/connector to ensure nothing is damaged.
    Get a new Mopar rear diff speed sensor.
    You can check with dealer but I think the part# 56041393AA
    See this thread as well.
    https://www.jeepkj.com/threads/speedometer-issues.53547/
     
  3. tommudd

    tommudd Moderator Staff Member Moderator

    Messages:
    18,116
    Likes Received:
    524
    Joined:
    Jul 14, 2005
    Location:
    Southeastern Ohio
    99% of the time it is the wiring going from diff up to body, ( always near where entering body
     
    LibertyTC likes this.
  4. Billwill

    Billwill Full Access Member

    Messages:
    1,679
    Likes Received:
    249
    Joined:
    Nov 26, 2009
    Location:
    White River, South Africa
    Yeah I agree that 99% of the time the harness from the Diff Sensor gets damaged on its way from the sensor to the inside of the cabin to the ECM/PCM.

    The sensor definitely mounts on the outside of the diff ...not internaly!

    There is an FSM out for ALL 2005 KJs Gas or Diesel that the rear Diffs may have had the wrong diff oil put into the diffs at the time of manufacture. This incorrect oil slowly chewed up the sensor.

    Fix was for the dealers to drain the diff oil, clean out the diff, fill up with correct oil, replace the Diff sensor.

    On my 2002 Export CRD I found a bad connection on the diff sensor.
    After I fixed the problem the speedo worked but red CEL light stayed ON for about a week then went out.;)
     
    Last edited: Sep 15, 2020