Search results

  1. R

    Little to no heat

    Thanks for the suggestions guys. I will try to work through some of these this weekend.
  2. R

    Little to no heat

    The radiator is 3 years old. New heater core and blend door actuator two years ago. I can hear the actuator cycling. The tank and cap was replaced with the heater core. Barely warm at best. On the throttle it would get a bit warmer, but coming to a stop back to barley warm. Some suggested...
  3. R

    Heater problem

    No i have not changed it. I will have to get the pressure tester from autozone. Thank you
  4. R

    Heater problem

    I have an 02 That I have replaced the heater core and blend door within the last 2 years. The blower motor was not working and found the problem to be the connector to the motor. The blower motor resistor was also replaced to get all four speeds to work. All of those items seem to be functioning...
  5. R

    blower motor connector

    Thank you .. cutting it off and going direct was in my head and may do that. Didn't like the idea at first. I may try to find something at a yard first. Thank you for looking. I wasn't sure if i was using the wrong description when searching or not.
  6. R

    blower motor connector

    Can anyone help with a part number for a blower motor connector? The parts store did not show one today. I have tried to find one online tonight with no luck. There are several for the resistor, but I need the one for the motor itself. Thank you
  7. R

    Blower motor connector

    Can anyone help with a part number for a blower motor connector? The parts store did not show one today. I have tried to find one online tonight with no luck. There are several for the resistor, but I need the one for the motor itself. Thank you
  8. R

    Blower motor / resistor

    Now I have a bigger problem. The parts guy told me to let him warranty the resistor without testing. It was 2yrs old . Put the new one in tonight and no change. Blower does not come on. Had other things going on tonight so I didn't have any time to go much further. I did probe the back of each...
  9. R

    Heater core question

    I went through the same procedure on an 02' two years ago. I did have to replace the heater core. My not have been needed but I also did the blend door actuator while that deep into it.
  10. R

    Blower motor / resistor

    The blower does not operate on any of the four speeds. I replaced the resistor with a Durolast part from autozone a couple years ago. It still looks brand new. Is there a way to test it? I pulled the blower and it has plenty of power on 12v. I also checked and swapped relays under the hood...
  11. R

    Grinding noise when going from Park to Reverse

    No leaks. Output bearing ? Assuming that will be inside the pump housing? it is an automatic. Thank you for the manual! There is a lot of reading and information in there.
  12. R

    Grinding noise when going from Park to Reverse

    Thank you Eric. No, although it may also do it in 4 wheel it is in 2 wheel right now. thank you for responding. I really am not sure where to start. I do know that the shifter lever does have a bit more play in it than I think it should have and maybe that is the issue. I'm lost
  13. R

    Grinding noise when going from Park to Reverse

    Any other ideas on where I can search for information? Thank you
  14. R

    Grinding noise when going from Park to Reverse

    Still trying to figure out where this is coming from. Today I moved it around the driveway a little. It did not do going from park to reverse , but did start while backing up. Went to neutral and back to reverse and it quit. While driving forward it did it in drive. I opened the door trying to...
  15. R

    Grinding noise when going from Park to Reverse

    When shifting from park to reverse on an 06' there is a grinding/whining noise. If I go to drive and back into reverse it does not happen. It is not every time but fairly consistent. Fluid is clean and the right color. It sounds like it is right under the shift lever. Any ideas on what to start...
  16. R

    Transfer case / transmission ? Where to start?

    We have an 06 with 150k miles. It has started having a couple issues that I don't think are related but I'm also not sure. Sometimes when shifting from park to reverse it sounds like its lightly grinding. Put it back in park and shift again it is ok. The shift handle does have some play in it. I...
  17. R

    02 sensor help please 06 3.7

    Thank you Royy
  18. R

    02 sensor help please 06 3.7

    yes. a p0157 and the light is on all the time. I checked for broken or burnt wires and had no problems there.
  19. R

    02 sensor help please 06 3.7

    I need to replace the bank 2 sensor 2 unit down stream. If I am correct the oem # is 56029049aa... which looks like it crosses to ngk 23159 . Some sites show it to be the incorrect part and some show it being correct. Anyone know or have experience with the correct part? Thank you for your help.
  20. R

    Starting /running help on 06

    Thank you for the link. I will see.if i am smart enough to read through it. This car worked fine for 2 days. Now this morning the same thing again. It sat for 2hrs today and did it again. Left work and went to a night class 3yrs tonight. Will see.what happens in. Couple hours. When it gets...

Latest posts

Members online

Top