Go Back   Jeep Liberty Forum - JeepKJ Country > Members List




Conundrum2006 Conundrum2006 is offline

Member

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. Conundrum2006
    04-06-2016 05:45 PM - permalink
    Conundrum2006
    Cool. Glad they got there so quickly. BTW the water pump bolts are correctly labeled, not sure which bag the timing cover bolts were put in.
  2. CodeWarrior
    04-05-2016 07:57 PM - permalink
    CodeWarrior
    Awesome, I got the bolts and the sensor yesterday. Thanks again!

    Cory

About Me

  • About Conundrum2006
    First Name
    Paul
    Location
    Alabama

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Today 12:37 AM
  • Join Date: 12-09-2015
  • Referrals: 0

Likes Given

155 Likes
  1. Conundrum2006
    Conundrum2006 liked post by 04Liberty On thread : Possible engine swap on 05 liberty renegade
    Here we ago again lol
    Liked On: 03-07-2018, 11:17 PM
    Posted On: 03-07-2018, 10:04 AM
  2. Conundrum2006
    Conundrum2006 liked post by KrazyK On thread : O2 sensors in pairs?
  3. Conundrum2006
    Conundrum2006 liked post by HoosierJeeper On thread : Great..
    Looks like a Ujoint failure to me? How old where they? Any symptoms of them being bad?
    Liked On: 02-18-2018, 12:52 PM
    Posted On: 02-18-2018, 08:54 AM
  4. Conundrum2006
    Conundrum2006 liked post by ltd02 On thread : engine problems PLEASE HELP!
    Check out this thread: http://www.jeepkj.com/forum/f202/engine-swap-overview-53270/
    Liked On: 02-14-2018, 10:01 PM
    Posted On: 02-14-2018, 09:01 PM
  5. Conundrum2006
  6. Conundrum2006
  7. Conundrum2006
  8. Conundrum2006
  9. Conundrum2006
    Conundrum2006 liked post by JasonJ On thread : What would you do from here?
  10. Conundrum2006
    Conundrum2006 liked post by justjeeps On thread : Camshaft position sensor error
  11. Conundrum2006
  12. Conundrum2006
    Conundrum2006 liked post by justjeeps On thread : Camshaft position sensor error
  13. Conundrum2006
    Conundrum2006 liked post by tjkj2002 On thread : Camshaft position sensor error
    Those 2 statements tell me the timing is not set right since P0344 is cam/crank correlation code.
    Liked On: 10-23-2017, 08:40 AM
    Posted On: 10-22-2017, 10:12 PM
  14. Conundrum2006
    Conundrum2006 liked post by BillyG On thread : Hoping for a miracle
    Mine had that and it was the upstream O2 sensor
    Liked On: 10-17-2017, 01:00 PM
    Posted On: 10-16-2017, 12:41 PM
  15. Conundrum2006



GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum