Go Back   Jeep Liberty Forum - JeepKJ Country > Members List

Register to remove these ads.




Billwill Billwill is offline

Member

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. Billwill
    05-28-2017 05:12 AM - permalink
    Billwill
    Hi, Do you have a RED LED on the left side of the cluster either ON all the time as soon as ignition is turned ON? The earlier KJs do not have this red LED but instead has an amber ""Key"icon with a stripe through..same applies..is it ON or Flashing. This is for the SKIS anti-theft system so first try another chipped key...assuming you have SKIS installed! Do you have the Žngine"icon lit ie. pointing to some engine problem.

    You need to hear if your fuel pump starts to run at the rear as soon as ignition is turned ON otherwise you get no fuel up front to the motor...once again check all fuses.If the fuel pump is not running and fuses are OK....remove the Fuel Pump Relay from the box under the hood. Locate the female pins 30 and 87 inside the empty relay socket and jumper t em together with a piece of wire,,,if pump now runs try starting the motor.

    If you do not come right get back to me and I will advise you further!
  2. Billwill
    12-03-2014 05:05 AM - permalink
    Billwill
    Hi, You need to join this forum and post your problem so that all members can come up with suggestions. I have never heard of an IOD fuse....check all the fuses in the box under the hood and the fuse panel inside the cabin.
    You need to get the stored codes read out, try the "key" trick. Turn the ignition ON/OFF rapidly 4 times. After the 4th time leave the ignition ON. The Odometer display should read out the stored codes from the oldest...which may no longer be valid...to the latest. Otherwise a common problem is the Crankshaft Sensor or the Camshaft sensor....only replace with genuine OEM parts! You can download the Jeep KJ Service Manual here...includes the codes and the circuit diagrams. The 2004 version is not listed but the 2003 KJ Service Manual should be close enough. Also try jeepforum.com and lostjeeps.com.

    Service Manual download:
    Index of /manuals/Jeep/KJ
  3. bmeliza
    12-02-2014 11:44 PM - permalink
    bmeliza
    Hi,
    you were recommended as a good source in one of the electronics posts. I had some issues with a head unit installation and had a blown fuse that impacted the power locks, interior lights, and gauges. I replaced the fuse and all came back on and seemed to work OK, but now car won't start. It's getting plenty of juice and cranks but won't catch. several forums on web suggested IOD fuse. funny thing is I cannot find any good information on where it's located on a 2004 Liberty. Plenty of detailed pics for other Jeep models but nothing on Liberty. Can you help me? Also, any other thoughts you have on other potential solutions would be much appreciated.

    thanks for your time/expertise,
    Baron Meliza
    Dallas, TX

About Me

  • About Billwill
    First Name
    Bill
    Location
    White River, South Africa
    Biography
    Back White River Bushveld fortunately.
    Interests
    Drives in Kruger National Park
    Occupation
    Retired

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 03:03 AM
  • Join Date: 11-26-2009
  • Referrals: 2

Friends

Showing Friends 1 to 1 of 1



GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum