Go Back   Jeep Liberty Forum - JeepKJ Country > JeepKJ.com -Jeep KJ Country > Just registered? Post here to introduce yourself!



Just registered? Post here to introduce yourself!

New to Jeep KJ


This is a discussion on New to Jeep KJ within the Just registered? Post here to introduce yourself! forums, part of the JeepKJ.com -Jeep KJ Country category!
I think there is at least one how to on this forum about adding one or upgrading. Here's a link: ...

Just registered? Post here to introduce yourself!


Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 12-31-2018, 09:45 PM   #51 (permalink)
 
ltd02's Avatar
Supporting Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,321
Default

I think there is at least one how to on this forum about adding one or upgrading.

Here's a link: HOW TO: Install an EVIC or OTIS (overhead computer)
__________________
02blue reincarnated.
2005 Limited STS(71k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 12-31-2018, 11:57 PM   #52 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

This looks like a good one . So beside the ambient temp sensor, do I also need the bracket to attach to the 05 roof ?

https://www.ebay.com/itm/99-04-OEM-G...edirect=mobile
Mytmouse is offline   Reply With Quote
Old 01-01-2019, 12:09 AM   #53 (permalink)
 
ltd02's Avatar
Supporting Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,321
Default

My 05 came with the EVIC installed. I've never done an install so maybe someone who has will be along soon.
__________________
02blue reincarnated.
2005 Limited STS(71k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 01-01-2019, 05:14 PM   #54 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

Well reading through ALL these threads on EVIC installs, I went ahead and ordered a console retainer bracket p/n 5072348AA for $22 +s&h. Now my only things are from reading all these threads, I'm not sure if the EVIC I ordered from Ebay is right for my 05, and if it has the wire harness or at least the connector for me to make my own harness.
I sent a note to the seller asking, but I'm not expecting a quick response.
It figures that the plug/harness is hard to find, and expensive. Worse case I think I read, I can make something from an old floppy drive connector or something.

Funny thing is, this all started just because I didn't want the annoying horn chirp when locking the doors with the key fob.
Which I already fixed by following this :

To DISABLE (cancel) the horn chirp feature,
Press and hold the transmitter LOCK button for four to ten seconds.
While pressing the LOCK button in, press the PANIC button.
Release both buttons.

Worked like a charm.

But now I'm hooked/determined to get this EVIC with all the other features and programming choices it offers.... And spending more $$$$ that I didn't intend on.

.
ltd02 likes this.
Mytmouse is offline   Reply With Quote
Old 01-01-2019, 05:31 PM   #55 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

Ok, I think I'm ok - ok but not great...
Looking closer at the Ebay EVIC pictures I see the connectors for the lights AND the EVIC with small stubs of wire out of each. Maybe just enough for me to solder 4 wire trailer wiring to.

And according to the "Installing an OTIS" how to web page it's the latest EVIC #56042756AJ

s-l500.jpg

Last edited by Mytmouse; 01-01-2019 at 05:52 PM.
Mytmouse is offline   Reply With Quote
Old 01-02-2019, 03:09 PM   #56 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

Dag nab it - so the console retainer bracket p/n 5072348AA I order online, came back as cancelled order due to discontinued part.
So I guess my search for another console retainer bracket p/n 5072348AA is back on.


.
Mytmouse is offline   Reply With Quote
Old 01-02-2019, 05:41 PM   #57 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default Please Help identify correct part

Ok, I went to my local auto wreckers and they came back with this (see below link for pictures).....

I'm not 100% sure - they said it came out of a Cherokee.

Is this what the retainer bracket is supposed to look like ? The numbers on it don't look like the p/n number I got from the threads here...
Please advise?
https://photos.app.goo.gl/5pxbjDhWszisXY1G8


.
Mytmouse is offline   Reply With Quote
Old 01-03-2019, 03:54 PM   #58 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

If that is the correct retainer bracket (I'll know for sure when my EVIC from EBAY arrives, I suppose) how has the 3m tape method work out in the long run through hot & cold temps for you guys?
If not someone suggested to me to use E6000 glue.....
Mytmouse is offline   Reply With Quote
Old 01-12-2019, 03:02 PM   #59 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

​Ok I thought I had everything figured out and got all my necessary parts. I finally had some time to do this mod. First thing stopped me in my tracks - that is that the dome courtesy light plug / wiring is totally different in my 05 Liberty than the EVIC (56042756AJ) I got from Ebay. I'm going cross eyed from all of the 40+ pages from the HOW TO: Install an EVIC thread - I can't find the wiring difference and /or solution to this. Can anyone HELP!

see link for pictures dome courtesy light plug / wiring differences

https://photos.app.goo.gl/iPu1Z4SYpL8RpCTD6



.
Mytmouse is offline   Reply With Quote
Old 01-13-2019, 10:16 AM   #60 (permalink)
Member

 
Join Date: Dec 2018
Location: New York
Posts: 162
Default

I figured out/found the courtesy dome light plug wiring and lights working backwards dilemma from post #96 & #97 from the HOW TO Install an EVIC thread. Now I just have to figure out how to change/move the wiring within the plug.

As I mentioned last night I hook up the EVIC and powered it up briefly. I did not cut the head linener/mount it yet - the no turning back portion, until I was sure everything is working. All seems to be working except the Temperature reads --F .
The EVIC I got is from a 2004 GC, which reading here, multiple times, says an 04 or newer EVIC will work for my 05 Liberty temp reading to work. I do have a temp sensor installed, even purchased an additional new one, same result. Some say it might just need to register different temps for more than 5 min. I have the Liberty still in my garage as I'm working on other things, so I haven't kept it on longer than 5 min.
I have a few other issues like only one tire is not reading pressure, but the other three show 33,33,32 , I didn't even think I had TPMS sensors in ths tires?..?..?. Also only the front drivers and front passengers door register open/closed, not the any of the rear doors or glass/gate, but still does show on the dash.

See pics - I used tap a fuse on #13 fuse position, and the OBD adapter worked out nice , hope the cutting of the headliner comes out as well..
https://photos.app.goo.gl/URTiTA7KL2sDZ93C6


-TC
_______
[_] [___]
l-----{o||||o}
()_) ()_)-o-)_)

"Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the present." -Master Oogway (KungFu Panda)
Mytmouse is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum