Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KK (08-Present) > How To



How To

2010 Liberty Sport Blend Door Issues and Repair!!!


This is a discussion on 2010 Liberty Sport Blend Door Issues and Repair!!! within the How To forums, part of the Jeep Liberty - KK (08-Present) category!
Hello I wanted to share this info with other 2010 Liberty owners ..which I just fixed on mine. When I ...

How to Section for the KK


Reply
 
LinkBack Thread Tools Display Modes
Old 06-20-2014, 10:50 PM   #1 (permalink)
Member

 
Join Date: Jun 2014
Location: new york
Posts: 1
Smile 2010 Liberty Sport Blend Door Issues and Repair!!!

Hello I wanted to share this info with other 2010 Liberty owners ..which I just fixed on mine. When I turned on the blower it would get stuck in the feet position only no matter what position the switch was on. Thinking it was the blend door, I simply pulled down the access panel under the steering column ..took out both actuator motors and turned by hand the blend doors. They felt a little stiff so I sprayed some lubrication .It turned out the motor was bad on the heat or cold air blend and not the direction blend door!! Weird!! Got aftermarket Dorman actuator motor for 30.00 and everything is like new!!! Very simple repair...Need a T10 Torx bit for the screws on the motors and thats it!!
rmp608 is offline   Reply With Quote
Old 08-21-2016, 11:27 PM   #2 (permalink)
Member

 
Join Date: Aug 2016
Location: Colorado Springs, CO
Age: 38
Posts: 6
Default 2010 Jeep Liberty Heat blowing out cold air

rmp608, I think I have the same problem that you were having. I know you stated that the blend door was located on the driver side underneath the steering column, but you wouldn't happen to have pictures of it? Sorry, i am just trying to save some money before I have to take it to the dealership to diagnosis it with their fancy computer. I have looked the price up for the actuator and it's around $35, so that isn't bad.
grunt3327 is offline   Reply With Quote
Old 10-28-2017, 09:11 PM   #3 (permalink)
Member

 
Join Date: Oct 2017
Location: Lockport, Il
Posts: 2
Default

I'm having the same problem but in reverse. It stays on defroster.....I can get it to go to the vents but not the floor......by the way...how many actuators does the 2012 liberty have??
Mastermechanic is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum