Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KK (08-Present) > KK General Discussion



KK General Discussion

Alternator & Battery Fail; Transmission Locked in Park


This is a discussion on Alternator & Battery Fail; Transmission Locked in Park within the KK General Discussion forums, part of the Jeep Liberty - KK (08-Present) category!
We installed the alternator, battery, and serpentine belt last night in blizzard conditions. We had to keep a blanket on ...

General discussion forum for KK Liberty's


Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 04-16-2018, 10:33 AM   #11 (permalink)
Member

 
Join Date: Aug 2017
Location: MN
Age: 59
Posts: 37
Default





We installed the alternator, battery, and serpentine belt last night in blizzard conditions. We had to keep a blanket on the engine to keep a snow drift from forming in the engine bay. We got it all done and all is good. We never did get the transmission lock to release by inserting and twisting the ignition key; it would come out of park and stop half way to R. We cleared off the hood and windshield of the Liberty when we started and you can see what accumulated since. I included a pic of my 2010 Patriot parked on the street. I had to dig it out this morning for going to work.
steverose359@gmail.com is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum