Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > How To



How To

03' Liberty Evap sys- not ready? (emissons test)


This is a discussion on 03' Liberty Evap sys- not ready? (emissons test) within the How To forums, part of the Jeep Liberty - KJ (02 to 07) category!
I recently had work done on the fuel system, and the shop noticed my battery ambient sensor was missing. I ...

In this section it explains how to do installations and modifications.


Reply
 
LinkBack Thread Tools Display Modes
Old 06-10-2011, 07:30 PM   #1 (permalink)
Member

 
Join Date: Jun 2011
Location: Annapolis
Age: 32
Posts: 1
Default 03' Liberty Evap sys- not ready? (emissons test)

I recently had work done on the fuel system, and the shop noticed my battery ambient sensor was missing. I replaced the part and drove me liberty for 3+ hours to complete a drive cycle (20+ stops, 10+ accelerations, 100+ miles high speeds, and 50+ miles for medium speeds) to reset the computer. However, when I went to get emissions my evap system and heater no 2, both said "not ready."

I'm not sure what to do for these anomalies in order to pass my emissions test. Any ideas?...
Jason0579 is offline   Reply With Quote
Old 06-10-2011, 09:49 PM   #2 (permalink)
Member

 
Join Date: May 2011
Location: Quebec
Age: 33
Posts: 58
Default

guuu...what a mess.... Try it again ?
simond is offline   Reply With Quote
Old 06-14-2011, 03:25 PM   #3 (permalink)
Member

 
Join Date: Nov 2009
Location: White River, South Africa
Age: 67
Posts: 999
Default

Wrong forum...place this in the "KJ General Discussion" above.
Billwill is offline   Reply With Quote
Old 04-11-2018, 06:31 PM   #4 (permalink)
Member

 
Join Date: Nov 2014
Location: nh
Posts: 7
Default

I'm having the same problem what ended up being the solution?
whthrse is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum