Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

yellow sludge in oil fill cap


This is a discussion on yellow sludge in oil fill cap within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! i just did my second oil change in my 06 KJ(6,300 miles on ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2007, 08:04 PM   #1 (permalink)
b2
Member

 
Join Date: Aug 2006
Location: denville, NJ
Posts: 5
Default yellow sludge in oil fill cap


Register to remove these ads. It's free!
i just did my second oil change in my 06 KJ(6,300 miles on it). when i opened my oil fill cap i saw some yellow sludge in the tube, and some yellow/orange bubbles on the bottom of the cap. the rest of the oil that came out of the oil pan was fine(no colors/sludge). both changes that i have done have been with Mobil 1 full synthetic. anyone had any similar experiences. im hoping that those bubbles dont mean that i have coolant in my oil. thanks for your help,
__________________
2006 KJ Sport for DD
90 XJ rusty's 9" long arm kit, 35" MTR's, mini spool in the rear, aussie locker in the front with 4.88's, NP 435 tranny
b2 is offline   Reply With Quote
Old 01-18-2007, 08:11 PM   #2 (permalink)
Member

 
Join Date: Dec 2004
Location: Midwest
Posts: 939
Default

not sure if it's the case in this instance, but it could be condensation. i've seen it before on others vehicles (maybe even our old '02 kj) we've owned. either way, i was always told not to worry about it.
dnm45227 is offline   Reply With Quote
Old 01-18-2007, 08:23 PM   #3 (permalink)
 
Marlon_JB2's Avatar
Kombat Edition Jeep

 
Join Date: Nov 2004
Location: Detroit, MI
Age: 30
Posts: 14,794
Default

Condensation. Don't worry about it...

I've been told that it comes from taking lots of short trips. Well that was my case...
__________________
[---'17 KL Trailhawk - Rhino - 3.2L - 948TE - 245/65R17 Destination A/Ts...more to come
---'02 DN Durango - Project - Guy said it needed an engine. Needed an oxygen sensor. - Stock - Keeping it that way.]


KJ Country's Resident Jeep Employee!
Marlon_JB2 is offline   Reply With Quote
Old 01-18-2007, 08:39 PM   #4 (permalink)
Member

 
Join Date: Jan 2005
Location: Dayton Ohio
Posts: 501
Send a message via AIM to Eddo
Default

Condensation mixed with oil. You will see it if you live in a humid climate and take lots of short trips. Had it happen to me. Seen it on other cars.
__________________
2003 Liberty Limited
Eddo is offline   Reply With Quote
Old 01-18-2007, 08:43 PM   #5 (permalink)
 
2003KJ's Avatar
Member

 
Join Date: Sep 2004
Location: Planet Earth
Posts: 5,323
Default

Condensation, however I would be slightly worried. Condensation that forms in the oil needs to be burned off, and this happens by the engine getting up to temperature, and the engine oil getting good and hot. If not, over time, the condensation will start to form sludge inside your engine...and that's not good. However, running Synthetic helps to cut back on the ammount of sludge that forms.

Short trips, where the engine either does not, or just barely gets completely warmed up are what causes this. Thats why I usually make it a point to drive around the block if I know i'm making a real short trip. I'd rather spend the extra in gas now then later on down the line have issues with that crap inside my engine.
__________________
-Tim

JeepKJ Country Member #003
-2003 Khaki KJ Sport V-6
-NP 231 Command-Trac
-42RLE Automatic (perhaps the first KJ with the 42RLE)
-235/70/R16 Bridgestone Dueler A/T REVO's

Please help support the site! With out your support, we wouldn't be here!!! To contribute CLICK HERE!!!

They arrested me for being drunk in pubLIC.....I didn't wanna be drunk in pubLIC....I wanted to be drunk in a bar!!!! They threw me in pubLIC....arrest them!!!

2003KJ is offline   Reply With Quote
Old 01-18-2007, 08:45 PM   #6 (permalink)
 
cowdogg's Avatar
Member

 
Join Date: Jul 2006
Location: Chandler, AZ
Posts: 77
Default

It's condensation, don't worry about it.
cowdogg is offline   Reply With Quote
Old 01-19-2007, 12:58 AM   #7 (permalink)
 
Dave's Avatar
Administrator


 
Join Date: Feb 2006
Location: on here
Posts: 15,425
Default

Originally Posted by 2003KJ
Short trips, where the engine either does not, or just barely gets completely warmed up are what causes this. Thats why I usually make it a point to drive around the block if I know i'm making a real short trip. I'd rather spend the extra in gas now then later on down the line have issues with that crap inside my engine.
That's funny as I do the same thing or combine a couple of errands into one longer trip. I change my own oil and have never noticed any condensation.

Ever notice if you change your own oil that when you take the oil filler cap off there is a removable splash guard in the filler neck. I check that too and it's always clean.

Dave
__________________
05 Black KJ.....aka "The Pig".....
Lifted, Bent Rock Rail, and "Minor Organic Trail Rash".....

Need More Stuff..

Become a Supporting Member
http://www.jeepkj.com/forum/payments.php
Dave is offline   Reply With Quote
Old 01-28-2007, 12:28 PM   #8 (permalink)
 
rxraptor02's Avatar
Member

 
Join Date: Oct 2006
Location: Indiana
Posts: 93
Send a message via AIM to rxraptor02
Default

I noticed the sludge buildup on my oild cap/pulg thing last night when I went through the local quick stop oil change place.

I know it is Condensation however I do not make any short trips. I only have 12,200 miles on my Liberty.

The humidity is not that high right now, so is there any other explination as to why this is happening?
__________________
06 Liberty Sport
rxraptor02 is offline   Reply With Quote
Old 01-28-2007, 12:57 PM   #9 (permalink)
 
Dave's Avatar
Administrator


 
Join Date: Feb 2006
Location: on here
Posts: 15,425
Default

Originally Posted by rxraptor02
I noticed the sludge buildup on my oild cap/pulg thing last night when I went through the local quick stop oil change place.

I know it is Condensation however I do not make any short trips. I only have 12,200 miles on my Liberty.

The humidity is not that high right now, so is there any other explination as to why this is happening?
I wonder what kind of oil they use??? I have been using Mobil 1 and havn't had that problem. Could it be the brand or type (synthetic - verses dino) of oil that makes a difference????

I don't know, just thinking out loud here.

Dave
__________________
05 Black KJ.....aka "The Pig".....
Lifted, Bent Rock Rail, and "Minor Organic Trail Rash".....

Need More Stuff..

Become a Supporting Member
http://www.jeepkj.com/forum/payments.php
Dave is offline   Reply With Quote
Old 01-28-2007, 01:03 PM   #10 (permalink)
 
Marlon_JB2's Avatar
Kombat Edition Jeep

 
Join Date: Nov 2004
Location: Detroit, MI
Age: 30
Posts: 14,794
Default


Register to remove these ads. It's free!
Originally Posted by Dave
Originally Posted by rxraptor02
I noticed the sludge buildup on my oild cap/pulg thing last night when I went through the local quick stop oil change place.

I know it is Condensation however I do not make any short trips. I only have 12,200 miles on my Liberty.

The humidity is not that high right now, so is there any other explination as to why this is happening?
I wonder what kind of oil they use??? I have been using Mobil 1 and havn't had that problem. Could it be the brand or type (synthetic - verses dino) of oil that makes a difference????

I don't know, just thinking out loud here.

Dave
I've heard that synthetic or dino... doesn't matter, the issue still occurs.
__________________
[---'17 KL Trailhawk - Rhino - 3.2L - 948TE - 245/65R17 Destination A/Ts...more to come
---'02 DN Durango - Project - Guy said it needed an engine. Needed an oxygen sensor. - Stock - Keeping it that way.]


KJ Country's Resident Jeep Employee!
Marlon_JB2 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum