Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

turn signal not working


This is a discussion on turn signal not working within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! so lights were all working today, stopped for a bite to eat got ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 05-20-2012, 08:27 PM   #1 (permalink)
 
kjwindsor's Avatar
Member

 
Join Date: May 2012
Location: windsor
Age: 34
Posts: 3
Default turn signal not working


Register to remove these ads. It's free!
so lights were all working today, stopped for a bite to eat got back in and the turn signals do not work.

4ways flash, lights work when the you lock and unlock, just when you try and used the turn indicator the lights do not come on for the dash as well as the lights do not come on either......i have checked the fuses but i do not know where to go from here....
kjwindsor is offline   Reply With Quote
Old 05-20-2012, 09:19 PM   #2 (permalink)
Banned

 
Join Date: Dec 2006
Location: Slightly North of the 49 th. Parallel... In HongCouver
Age: 52
Posts: 9,311
Default

Welcome to the site.

An introduction wouldn't hurt Eh!
Ry' N Jen is offline   Reply With Quote
Old 05-21-2012, 12:12 AM   #3 (permalink)
 
Paul M's Avatar
Member

 
Join Date: Jun 2009
Location: Virginia Dale, Colorado
Posts: 249
Default

Sounds like the turnsignal stalk is the culprit...check the connectors and/or wiring underneath the dash.
__________________
2007 White KJ Sport, Light Bar, Skid Plates, Elbrus Wheels, 245/75-16 GY Silent Armour Tires, Rola Basket, Cool ranch dog in back
Paul M is offline   Reply With Quote
Old 05-21-2012, 09:59 AM   #4 (permalink)
Member

 
Join Date: Nov 2009
Location: White River, South Africa
Age: 66
Posts: 925
Default

Definitely sound like the multi-function switch....that is the switch that has the stalks going out to the left and the right.
The multi-function switch picks up power direct from the hazard flasher unit...the fact that the hazard lights work means the basic wiring to the bulbs is OK...the green arrow LED on the console is in parallel with the light bulbs.
You need to remove the two plastic covers around the steering column by removing two small female Torx screws from underneath.

There are two type of multi-function switch available...one for KJs with front fog/driving lights and one for KJ without those lights.
Billwill is offline   Reply With Quote
Old 05-23-2012, 05:22 PM   #5 (permalink)
 
kjwindsor's Avatar
Member

 
Join Date: May 2012
Location: windsor
Age: 34
Posts: 3
Default

sorry about the lack of saying Hi and all that with my first message, I am happy to have found this site and have feedback from fellow KJ owners!

So over the past couple days I have replaced the turn signal stalk, still nothing......talked to the guys at chrystlers they said it could be the flasher could be the problem.....just kinda sucks as im buying up all this electrical and no one takes returns.....
kjwindsor is offline   Reply With Quote
Old 05-24-2012, 10:22 AM   #6 (permalink)
Banned

 
Join Date: Dec 2006
Location: Slightly North of the 49 th. Parallel... In HongCouver
Age: 52
Posts: 9,311
Default

Have you replaced the flasher unit?

As far as the multi function switch goes, put your old one back in and save the new one
for when the original one does croak!
Sooner or later you'll need it.
Ry' N Jen is offline   Reply With Quote
Old 05-24-2012, 09:59 PM   #7 (permalink)
 
kjwindsor's Avatar
Member

 
Join Date: May 2012
Location: windsor
Age: 34
Posts: 3
Default

put the order in for the flasher, the only one I can find is attached to the hazzard button. is that the only one in a 2006?
kjwindsor is offline   Reply With Quote
Old 05-30-2012, 01:58 PM   #8 (permalink)
Member

 
Join Date: Jul 2011
Location: Hermosa Beach, CA
Posts: 92
Default

Just had similar craziness. Try replacing fuse number 9...even if it looks fine. That wasnt meant to ryme lol
surfRenegade is offline   Reply With Quote
Old 06-01-2012, 03:20 AM   #9 (permalink)
Member

 
Join Date: May 2012
Location: USA
Age: 40
Posts: 19
Default

I would suspect MFS... Multi Function Switch, not too hard to replace i have done one. RockAuto.com has them for a better price than the dealer.
widwesternjeepz is offline   Reply With Quote
Old 06-01-2012, 04:26 AM   #10 (permalink)
Member

 
Join Date: Nov 2009
Location: White River, South Africa
Age: 66
Posts: 925
Default


Register to remove these ads. It's free!
Originally Posted by widwesternjeepz View Post
I would suspect MFS... Multi Function Switch, not too hard to replace i have done one. RockAuto.com has them for a better price than the dealer.
The OP has stated that he has changed that already ie. the turn signal stalk.
Billwill is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum