Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

Throttle Position Sensor - Recurring Issues


This is a discussion on Throttle Position Sensor - Recurring Issues within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! Hi All, Have an 02 3.7L with around 93k on it now. About ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 05-30-2011, 10:45 PM   #1 (permalink)
Member

 
Join Date: Oct 2006
Location: Pottstown PA.
Posts: 5
Default Throttle Position Sensor - Recurring Issues


Register to remove these ads. It's free!
Hi All,

Have an 02 3.7L with around 93k on it now. About 10 months ago I replaced the TPS due to erratic idling and occasional hesitation when driving (I did the key trick to get the codes so knew the TPS to be the cause). I also cleaned the IAC at the same time.

It's ran like a champ in the interim until last week. Family and I were about half way through a 600 mile trek to Outer Banks in NC when there was some violent jerking which lasted a few seconds, went away, came back again a few minutes later. CEL light came on so I pulled over and checked the codes (p0121 and p0123) which leads me to conclude that this is a recurrence of the previous problem. I removed the TPS wiring connector, blew in it to remove any debris and replaced it. No further recurrence (and CEL light eventually went out) until a week later when we were half way through making the return trip. The KJ hesitated abruptly a couple of times and then was fine for the remainder of the journey. This last hesitation occurred just as a heavy rainstorm started (not sure if that is relevant).

Does anyone have any suggestions as to why this problem may be recurring other than my 10-month old TPS has gone bad (which seems unlikely). The truck is my wifes daily driver and I don't want her to end up getting stuck somewhere in the current 90 degree heat.

Any help greatly appreciated as always.

Davy
corrado15 is offline   Reply With Quote
Old 05-30-2011, 10:48 PM   #2 (permalink)
 
tjkj2002's Avatar
Member

 
Join Date: Dec 2006
Location: Somewhere between being sane and insane!
Posts: 10,148
Default

If it's a aftermarket TPS I'm shocked it lasted 10 months,they rarely make it a few mins.Try a OEM MOPAR TPS,OEM sensors are worth the extra cost.
tjkj2002 is offline   Reply With Quote
Old 05-30-2011, 11:25 PM   #3 (permalink)
 
LibertyTC's Avatar
Member

 
Join Date: Oct 2008
Location: B.C. Canada
Posts: 5,488
Default

I am sure when it comes to sensors the OEM parts are better quality but what makes them more reliable? My curiosity now wondering, are aftermarket sensors not exacting enough in materials/workmanship/specs.... or what gives?
I doubt you can return these aftermarket sensors if used, so just stick to OEM.
__________________

Need A Push?
_______________________________
2004-OME Lifted-Bilstien-3/8 Top Steel Spacers-JBA4.5 A-Arms- PML Trans Pan-Riddler Cover-SpiderTrax Wheel Spacers-17"Silent Armor Tires-Setina PB400 PushBar-Rola Basket
Piaa Bulbs-Fogs 65W Mod- LED Puddle&Under Hood Lights- WeatherTech Mats/Mudflaps-Autel MaxiTrip OBDII Gauge& Scan Reader.
OCD & Addictive Jeep Disease When You Join this Forum! My Doctor Says "You need Help"!! I agreed, can I borrow some cash for the Jeep?
LibertyTC is offline   Reply With Quote
Old 05-31-2011, 04:56 PM   #4 (permalink)
Member

 
Join Date: May 2011
Location: ohio
Posts: 3
Default

sounds similar to a problem I've had recurring for almost a year. I have replaced the TPS twice and cleaned mas/maf. hasn't helped me yet.
pottsas is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum