Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

Malfunction Indicator Light


This is a discussion on Malfunction Indicator Light within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! Came on while I was driving home tonight, pulled over to check the ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 02-11-2010, 11:04 PM   #1 (permalink)
 
KJ zGal's Avatar
Member

 
Join Date: Nov 2008
Location: Warnerville, NY
Posts: 473
Send a message via AIM to KJ zGal
Default Malfunction Indicator Light


Register to remove these ads. It's free!
Came on while I was driving home tonight, pulled over to check the manual. Wasn't flashing or anything. Sounds/runs fine...what do I check and where? I'm assuming it's just a fluid issue...?
__________________
2002 Jeep Liberty Renegade w/185,600 miles
Light Khaki Metallic Clearcoat
(Replaced) 5-Speed Manual Transmission
Renegade hood decals
Pioneer Stereo install
Aero Turbine 2525 muffler install
Grabber AT2s (2nd set after 75k!) =


At least my vehicle can be plastered in mud, salt, and snow and still look good!
KJ zGal is offline   Reply With Quote
Old 02-11-2010, 11:30 PM   #2 (permalink)
 
jnaut's Avatar
Member

 
Join Date: Apr 2008
Location: Seattle
Posts: 2,237
Default

By 'malfunction indicator light' do you mean 'check engine light'? Regardless, to pull a code, put the key in the ignition, and without turning the jeep over (start position), turn key to:

on position
off position
on position
off position
on position

just like that, three times within about 5 second, and it will return a P code. If no codes are found, it will report "done" on the trip odometer.

If it is the CEL (check engine light) a common issue with that is a improperly secured gas cap. Happens with most modern vehicles. Check you gas cap regardless of the codes being reported.
__________________
-=Stock, but goin' places=-
04 3.7L Sport.
Auto Trans
Yokohama Geolandar AT/S 235/70/R16
Electronics: Garmin nuVi 265t GPS/ScanGauge II/Cobra 1500 watt (3000 peak) Inverter
Mileage trend:

I'm doing God's work...because he's too f*@$%ing lazy to do it himself.
jnaut is offline   Reply With Quote
Old 02-12-2010, 12:13 AM   #3 (permalink)
lil black liberty
Guest

 
Posts: n/a
Default

Just go to an Autozone and get them to run an OBDII test on it.. It's free and it will tell you the problem.. Or go buy one yourself I got mine I think for about $30 it's simple but it works like a charm!
  Reply With Quote
Old 02-12-2010, 01:11 AM   #4 (permalink)
 
KJ zGal's Avatar
Member

 
Join Date: Nov 2008
Location: Warnerville, NY
Posts: 473
Send a message via AIM to KJ zGal
Default

I have the auto computer that reads info from the OBDII but I have no idea how to work that portion of it or what to look for. And no, by malfunction indicator light I do not mean the check engine light...according to the manual it's something with the emissions, and is driveable unless flashing, in which case "severe catalytic converter damage may result and the vehicle must be serviced immediately." I assume the check engine light is different...and would say "check engine," lol, but as I've never had it come on before I wouldn't know. Gas cap is fine, I already checked it, and if it's bad fuel as the manual suggests it wouldn't make sense to me considering I've already run through almost 1/4 of the full tank I put in a day or so ago...not sure why the fuel would have suddenly turned poor quality.

My dad suggested tranny fluid, but considering it's a 5-speed I wasn't sure where/how to check this--not the same as an auto, I assume? I'm kind of just blabbering here because it's late and I haven't actually checked anything yet--I figured I'd have to check fluids when the vehicle was cold so I was planning to check in the morning before I have to go to school.
__________________
2002 Jeep Liberty Renegade w/185,600 miles
Light Khaki Metallic Clearcoat
(Replaced) 5-Speed Manual Transmission
Renegade hood decals
Pioneer Stereo install
Aero Turbine 2525 muffler install
Grabber AT2s (2nd set after 75k!) =


At least my vehicle can be plastered in mud, salt, and snow and still look good!
KJ zGal is offline   Reply With Quote
Old 02-12-2010, 01:21 AM   #5 (permalink)
 
liberty84's Avatar
Member

 
Join Date: Feb 2009
Location: Humble TX
Age: 32
Posts: 589
Default

Originally Posted by lil black liberty View Post
Just go to an Autozone and get them to run an OBDII test on it.. It's free and it will tell you the problem.. Or go buy one yourself I got mine I think for about $30 it's simple but it works like a charm!
X2
autozone does it for free, and by emission the first thing that come to my mind is...O2 sensors

hope evertying works out and that is something simple
__________________
05 Jeep KJ 2WD
K&N filter, OME/Rancho Lift, .250 clevis spacers,JBA 4.5 Gen A-arms, MOOG LBJ, Thrush Turbo muffler, Hella 500FF lights on trimmed bumper, removed rear sway bar, D-rings on front. 245/75/16, aussie locker, riddler diff. Cover

and still looks stock

Originally Posted by twack View Post
its a super heavy 1 wheel wonder.
not anymore....now it's a "super heavy 2 wheel wonder"
liberty84 is offline   Reply With Quote
Old 02-12-2010, 04:35 AM   #6 (permalink)
 
tjkj2002's Avatar
Member

 
Join Date: Dec 2006
Location: Somewhere between being sane and insane!
Posts: 10,147
Default

Originally Posted by KJ zGal View Post
I have the auto computer that reads info from the OBDII but I have no idea how to work that portion of it or what to look for. And no, by malfunction indicator light I do not mean the check engine light...according to the manual it's something with the emissions, and is driveable unless flashing, in which case "severe catalytic converter damage may result and the vehicle must be serviced immediately." I assume the check engine light is different...and would say "check engine," lol, but as I've never had it come on before I wouldn't know. Gas cap is fine, I already checked it, and if it's bad fuel as the manual suggests it wouldn't make sense to me considering I've already run through almost 1/4 of the full tank I put in a day or so ago...not sure why the fuel would have suddenly turned poor quality.

My dad suggested tranny fluid, but considering it's a 5-speed I wasn't sure where/how to check this--not the same as an auto, I assume? I'm kind of just blabbering here because it's late and I haven't actually checked anything yet--I figured I'd have to check fluids when the vehicle was cold so I was planning to check in the morning before I have to go to school.
Check engine light = Malfunction indicator light,they are 1 and the same.Could be one of about 10,000 different problems,or more then one problem.
tjkj2002 is offline   Reply With Quote
Old 02-12-2010, 06:57 AM   #7 (permalink)
 
KJ zGal's Avatar
Member

 
Join Date: Nov 2008
Location: Warnerville, NY
Posts: 473
Send a message via AIM to KJ zGal
Default

Ran the codes this morning...P1281, something with the thermostat, engine staying cold too long. Is this correct (found via Google), and what exactly does this entail as far as replacement costs?
__________________
2002 Jeep Liberty Renegade w/185,600 miles
Light Khaki Metallic Clearcoat
(Replaced) 5-Speed Manual Transmission
Renegade hood decals
Pioneer Stereo install
Aero Turbine 2525 muffler install
Grabber AT2s (2nd set after 75k!) =


At least my vehicle can be plastered in mud, salt, and snow and still look good!
KJ zGal is offline   Reply With Quote
Old 02-12-2010, 07:03 AM   #8 (permalink)
 
tjkj2002's Avatar
Member

 
Join Date: Dec 2006
Location: Somewhere between being sane and insane!
Posts: 10,147
Default

Originally Posted by KJ zGal View Post
Ran the codes this morning...P1281, something with the thermostat, engine staying cold too long. Is this correct (found via Google), and what exactly does this entail as far as replacement costs?
Stuck open t-stat,replace it.Looking at about $26 for the t-stat then about 1-2 gallons of 50/50 mix of HOAT coolant.

Last edited by tjkj2002; 02-12-2010 at 07:06 AM.
tjkj2002 is offline   Reply With Quote
Old 02-12-2010, 10:52 AM   #9 (permalink)
 
KJ zGal's Avatar
Member

 
Join Date: Nov 2008
Location: Warnerville, NY
Posts: 473
Send a message via AIM to KJ zGal
Default

I've got the coolant already, haven't put it in yet though. Is it safe to drive it tonight and work on it Saturday, or should I wait and take care of it before I drive it again? And do I have to put the coolant in after the thermostat is fixed or can I do it beforehand? Thanks for the help everyone =]

Edit: Btw, if the thermostat was stuck open, shouldn't it in theory be taking forever to heat up? Because it hasn't been doing that...and if it was stuck closed, it should in theory be overheating, which it also wasn't doing. And how do I know it's the thermostat and not a sensor somewhere? Or are they one and the same?
__________________
2002 Jeep Liberty Renegade w/185,600 miles
Light Khaki Metallic Clearcoat
(Replaced) 5-Speed Manual Transmission
Renegade hood decals
Pioneer Stereo install
Aero Turbine 2525 muffler install
Grabber AT2s (2nd set after 75k!) =


At least my vehicle can be plastered in mud, salt, and snow and still look good!

Last edited by KJ zGal; 02-12-2010 at 11:36 AM.
KJ zGal is offline   Reply With Quote
Old 02-12-2010, 01:50 PM   #10 (permalink)
 
jnaut's Avatar
Member

 
Join Date: Apr 2008
Location: Seattle
Posts: 2,237
Default


Register to remove these ads. It's free!
Originally Posted by liberty84 View Post
X2
autozone does it for free, and by emission the first thing that come to my mind is...O2 sensors

hope evertying works out and that is something simple
Or, you could do it in your driveway for free. Without an OBDII reader.
__________________
-=Stock, but goin' places=-
04 3.7L Sport.
Auto Trans
Yokohama Geolandar AT/S 235/70/R16
Electronics: Garmin nuVi 265t GPS/ScanGauge II/Cobra 1500 watt (3000 peak) Inverter
Mileage trend:

I'm doing God's work...because he's too f*@$%ing lazy to do it himself.
jnaut is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum