Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion

Register to remove these ads.



KJ General Discussion

Fuel level sensor


This is a discussion on Fuel level sensor within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
Register to remove these ads. It's free! my 2005 Liberty with the 2.4 engine is throwing a code PO463 Fuel ...

General discussion forum for KJ Liberty's


Reply
 
LinkBack Thread Tools Display Modes
Old 08-09-2010, 05:02 PM   #1 (permalink)
Ken
Member

 
Join Date: Jul 2007
Location: West Virginia
Age: 76
Posts: 40
Default Fuel level sensor


Register to remove these ads. It's free!
my 2005 Liberty with the 2.4 engine is throwing a code PO463 Fuel level sensor. How to fix. ???? Does one need to drop the tank to get to the sensor or maybe I can be lucky and it is just a loose connection or a ground. ????
Anyone else had this problem.
Does the 2005 have a access door in the floor in the rear.
Thanks in Advance
Ken
Ken is offline   Reply With Quote
Old 08-09-2010, 05:21 PM   #2 (permalink)
 
Mangate's Avatar
Member

 
Join Date: Apr 2005
Location: Mexico City
Posts: 237
Send a message via MSN to Mangate
Default

According to my 2005 FSM, yes you need to drop the tank. Does the fuel gauge read correctly?
__________________
2002 Liberty Sport
2003 Liberty Ltd.
Mangate is offline   Reply With Quote
Old 08-09-2010, 08:07 PM   #3 (permalink)
Ken
Member

 
Join Date: Jul 2007
Location: West Virginia
Age: 76
Posts: 40
Default

The gas gage reads correctly for about 50 miles and then beeps and goes to empty and the CEL comes on. After about 2 more starts the gas gage reads correctly till the next fill up. I always fill up so I can keep track of gas mileage. The CEL used to go out after maybe 5 starts but stays on all the time now. Had them clear the code at Advance Auto and I just filled up and all is well now will see what happens when I get 50 miles on it. Put a bottle of fuel system cleaner in with this fill up as well.
Laterz
Ken
Ken is offline   Reply With Quote
Old 08-09-2010, 08:14 PM   #4 (permalink)
 
Midgear's Avatar
Member

 
Join Date: Nov 2009
Location: Mcalester, OK
Age: 29
Posts: 899
Send a message via Yahoo to Midgear
Default

sounds like your sensor is about to take a dump..
__________________
Black 2002 Liberty Sport 4x4 08' Wrangler X 2 Door Soft Top
Originally Posted by tjkj2002 View Post
I just didn't give a s#!t.
Midgear is offline   Reply With Quote
Old 08-09-2010, 09:07 PM   #5 (permalink)
 
Mangate's Avatar
Member

 
Join Date: Apr 2005
Location: Mexico City
Posts: 237
Send a message via MSN to Mangate
Default

If the gauge always drops to zero at the same fuel level, then it probably is the sender (attached to the fuel pump module). If it'e completely random then I would have thought it is more likely a bad connection at the fuel pump plug.
__________________
2002 Liberty Sport
2003 Liberty Ltd.
Mangate is offline   Reply With Quote
Old 08-09-2010, 10:53 PM   #6 (permalink)
 
LibertyFever's Avatar
Member

 
Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 929
Default

Originally Posted by Mangate View Post
According to my 2005 FSM, yes you need to drop the tank. Does the fuel gauge read correctly?
My 04 Liberty is suffering from an incorrect fuel level reading, it never reaches "F" but it doesn't pop codes. I'm hoping that I can pull up the carpet above the tank and find an access panel.

Let us knw ho you make out Ken. And if you do the job yourself you'll have to take some pics for us.
__________________
95 Jeep YJ, 4" RE Lift, 33" Procomp Extreme M/T's, locked front & back, 4.88 gears and a Warn M8000 winch

04 Liberty Sport Jeep KJ with a 2.5" lift and ProComp LT245/75R16 AT tires

2010 Jeep Patriot North Edition
bone stock and going to stay that way
its the company car :-)
LibertyFever is offline   Reply With Quote
Old 08-10-2010, 01:01 AM   #7 (permalink)
 
Mangate's Avatar
Member

 
Join Date: Apr 2005
Location: Mexico City
Posts: 237
Send a message via MSN to Mangate
Default

Originally Posted by LibertyFever View Post
My 04 Liberty is suffering from an incorrect fuel level reading, it never reaches "F" but it doesn't pop codes. I'm hoping that I can pull up the carpet above the tank and find an access panel.

Let us knw ho you make out Ken. And if you do the job yourself you'll have to take some pics for us.
I don't have the FSM for 04, but the 03 is reached from under the carpet so I'd say yours will be the same.
__________________
2002 Liberty Sport
2003 Liberty Ltd.
Mangate is offline   Reply With Quote
Old 08-10-2010, 01:24 AM   #8 (permalink)
 
tjkj2002's Avatar
Member

 
Join Date: Dec 2006
Location: Somewhere between being sane and insane!
Posts: 10,417
Default

I can tell you my '02 does not have that access panel even though the FSM say's it is supposed to have one.My '02 is also one of the 1st ones made on the 2nd year production '02's so it's not a early built KJ.
tjkj2002 is offline   Reply With Quote
Old 08-14-2010, 10:06 AM   #9 (permalink)
Ken
Member

 
Join Date: Jul 2007
Location: West Virginia
Age: 76
Posts: 40
Default

I resolved the problems with the fuel gage by by buying a Diagnostic tool and clearing the codes.
Got over 100 miles on this tank of gas and no problems so far.
Laterz all
Ken
Ken is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum