Go Back   Jeep Liberty Forum - JeepKJ Country > Jeep Liberty - KJ (02 to 07) > KJ General Discussion



KJ General Discussion

engine problems PLEASE HELP!


This is a discussion on engine problems PLEASE HELP! within the KJ General Discussion forums, part of the Jeep Liberty - KJ (02 to 07) category!
I have a 2003 jeep liberty 3.7 and it started knocking. It's very loud I can hear it from inside ...

General discussion forum for KJ Liberty's


Like Tree9Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2018, 08:18 PM   #1 (permalink)
Member

 
Join Date: Aug 2017
Location: NY
Posts: 15
Default engine problems PLEASE HELP!

I have a 2003 jeep liberty 3.7 and it started knocking. It's very loud I can hear it from inside the jeep! It is also misfiring bad and don't have much power. It's doesn't make The noise all the time it does sometimes when idling and and when it's between 1500 to 2500 rpm. Sometimes it don't do it at all just runs rough. Anyone know what wood cause this? thanks for looking
Jeep liberty 3.7 is offline   Reply With Quote
Old 02-13-2018, 08:46 PM   #2 (permalink)
 
Conundrum2006's Avatar
Member

 
Join Date: Dec 2015
Location: Alabama
Age: 33
Posts: 434
Default engine problems PLEASE HELP!

Sorry to say the engine is about throw a rod or perhaps has dropped a valve shattering position.

Unfortunately I can’t think of anything that would make such a loud noise and misfires while being a minor problem.

Compression test will probably show 0 compression or compression below 100psi causing the misfire. Other possible causes bad spark plug, fuel injector,ignition coil.
If it dropped the valve maybe repair job to cylinder head, but with a sound like this my guess is catastrophic failure has happened or is about to.

Unless you have the background to rebuild I’d just try to source a good used engine. Maybe rebuilt if you can afford it.

However you can test to be sure, in this situation I’d do a compression test find the cylinder with bad compression and scope those cylinder to see what kind of damage there is. Automotive stethoscope to find where the sound originated.
I wouldn’t be driving this jeep or run the engine more than necessary.

Other here have a lot of experience with 3.7 engine and may have better advice.


Edit: forgot to say if you do test and the compression is good, then locating the sound is next. Very off chance the sound is transmission, torque converter bolt, something belt driven.

Test the belt driven by removing the belt. Test for rod knock by disconnecting the ignition coils one at a time to see is the noise goes away. We can get better instructions on these testing methods if you need them.


Sent from my iPhone using Tapatalk Pro

Last edited by Conundrum2006; 02-13-2018 at 08:56 PM.
Conundrum2006 is offline   Reply With Quote
Old 02-13-2018, 08:53 PM   #3 (permalink)
 
ltd02's Avatar
Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,601
Default

Do you have a CEL? Is it flashing? If you do, get the code. Pull the valve covers and have a look. Might just be a dropped rocker arm. Mine did this when the lash adjusters were failing. A new one fixed it and it wasn't that tough to do.
LibertyTC and Conundrum2006 like this.
__________________
02blue reincarnated.
2005 Limited STS(63k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 02-13-2018, 09:10 PM   #4 (permalink)
Member

 
Join Date: Feb 2018
Location: Washington
Age: 49
Posts: 79
Default

Originally Posted by ltd02 View Post
Do you have a CEL? Is it flashing? If you do, get the code. Pull the valve covers and have a look. Might just be a dropped rocker arm. Mine did this when the lash adjusters were failing. A new one fixed it and it wasn't that tough to do.
I guarantee you it's a valve, bad design on those. Entire rebuilt engine with a 5 yr unlimited warranty is $2500 on eBay, free shipping. If you go that way use synthetic oil in the new engine, seems to help with that.

Sent from my XT1650 using Tapatalk
Samsolo49 is offline   Reply With Quote
Old 02-13-2018, 09:25 PM   #5 (permalink)
 
ltd02's Avatar
Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,601
Default

Could be but maybe rule out the minor and simple things first before panicking. When I threw the #2 exhaust rocker I thought the thing was gonna explode. Did it three times over about a year. After the second time I bought a lash adjuster (Melling). When it dropped the third time I just installed the new adjuster while the rocker was off. Never did it again. And this was an engine that overheated bad a couple years earlier due to a failed fan relay.
emily_2000 likes this.
__________________
02blue reincarnated.
2005 Limited STS(63k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 02-13-2018, 09:27 PM   #6 (permalink)
Member

 
Join Date: Aug 2017
Location: NY
Posts: 15
Default

The check engine light is on and sometimes flashes..the codes are p0302 cylinder 2 misfire p0306 cylinder 6 misfire and a code for a bad oxygen sensor.. I'm thinking the rocker arm to because it was running grate I drove it about 60 miles Sunday. And Monday morning on my way to work it started making that noise and not running good
Jeep liberty 3.7 is offline   Reply With Quote
Old 02-13-2018, 09:42 PM   #7 (permalink)
 
ltd02's Avatar
Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,601
Default

Originally Posted by Jeep liberty 3.7 View Post
The check engine light is on and sometimes flashes..the codes are p0302 cylinder 2 misfire p0306 cylinder 6 misfire and a code for a bad oxygen sensor.. I'm thinking the rocker arm to because it was running grate I drove it about 60 miles Sunday. And Monday morning on my way to work it started making that noise and not running good
All you'd have to do is pull the right side valve cover and see both cylinders valves. I have to admit if these things drop valve seats they usually are #2 for some reason. I thought the worst when mine acted up but turned out to be nothing. If the rockers are okay then I'd start to think valve seat and do a compression check. You might even be able to see a tweaked valve just by looking. Was this engine ever overheated?

I also had a hard misfire (with flashing CEL) with a p0306. I shut it off and started it back up again about 30min later and no misfire or flashing CEL. Think I might have gotten some water or coolant in the plug/coil area of #6.

Now that I think of it, a few years back I had a wicked hard misfire (bucking and popping and sometimes a flashing CEL) that would come and go with my 2011 Avenger and it turned out to be an O2 sensor. I would wouldn't dismiss that either. That can cause some cylinder specific misfire codes too. Was yours an O2 sensor code on bank 2?
LibertyTC likes this.
__________________
02blue reincarnated.
2005 Limited STS(63k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 02-13-2018, 10:03 PM   #8 (permalink)
Member

 
Join Date: Aug 2017
Location: NY
Posts: 15
Default

I will pull the vale cover off tomorrow and check. I bought the jeep used almost 3 years ago and it's never overheated on me
LibertyTC and ltd02 like this.
Jeep liberty 3.7 is offline   Reply With Quote
Old 02-13-2018, 10:16 PM   #9 (permalink)
 
ltd02's Avatar
Member

 
Join Date: Aug 2014
Location: North Central Maryland
Posts: 2,601
Default

Not a bad idea to have a "scanner" that can do a bit of live data. Doesn't have to be too sophisticated but its real nice to see fuel trims and O2 sensor voltages on the fly when these things happen. Even a bluetooth type sender (< $20) and an app like torque (free version) will allow you to see some of this stuff.
__________________
02blue reincarnated.
2005 Limited STS(63k) 242/42rle/recall hitch/CrossContact 235-65-17/Bright Silver Metallic and shiny plastic covered wheels
2002 Limited (179k) "GONE"

"...if it is a Miracle, any sort of evidence will answer, but if it is a Fact, proof is necessary…." Mark Twain

"There was a time that the pieces fit, but I watched them fall away." -Tool
"To live without Hope is to Cease to live." -Dostoevsky
ltd02 is offline   Reply With Quote
Old 02-14-2018, 01:42 AM   #10 (permalink)
Member

 
Join Date: Aug 2013
Location: Red Deer, Alberta, Canada
Posts: 28
Default

If it idles like this, then it's a rocker.

https://youtu.be/NXRrOyIdEJA

The sound was worse with higher rpms and under load. I was able to limp home.

Last edited by kuench; 02-14-2018 at 01:45 AM.
kuench is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Dodge Ram Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum